CVE-2023-0872 ROLE_REST can be used to escalate to ROLE_ADMIN via /rest/users
Attackers with ROLE_REST can escalate to ROLE_ADMIN via the users endpoint, requiring an upgrade to secure the network monitoring platform.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-0872?
CVE-2023-0872 is a high-severity vulnerability in The OpenNMS Group Horizon, published on 14 Aug 2023. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
The Horizon REST API includes a users endpoint in OpenMNS Horizon 31.0.8 and versions earlier than 32.0.2 on multiple platforms is vulnerable to elevation of privilege. The solution is to upgrade to Meridian 2023.1.6, 2022.1.19, 2021.1.30, 2020.1.38 or Horizon 32.0.2 or newer. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet.
OpenNMS thanks Erik Wynter for reporting this issue.
Weakness: CWE-269
Which versions are affected by CVE-2023-0872?
2 open source packages ship an affected version, including org.opennms:opennms-webapp-rest. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
org.opennms:opennms-webapp-rest Maven | From 31.0.8 | 32.0.2 |
org.opennms:opennms-webapp-rest Maven | From 31.0.8 | 32.0.2 |
Products include Opennms Horizon, Opennms Meridian.
How do I fix CVE-2023-0872?
Upgrade org.opennms:opennms-webapp-rest to 32.0.2 or later.
Is CVE-2023-0872 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-0872 exists.
Public exploit code: 1 Metasploit module.
Other vulnerabilities in The OpenNMS Group Horizon
Sources
Also known as GHSA-w5gq-xrrp-3fxf.