{"answers":{"affected":"2 open source packages ship an affected version, including org.opennms:opennms-webapp-rest. It affects 2 products.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-0872 exists.","fix":"Upgrade org.opennms:opennms-webapp-rest to 32.0.2 or later.","what":"CVE-2023-0872 is a high-severity vulnerability in The OpenNMS Group Horizon, published on 14 Aug 2023. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-0872 and fix it if it is affected.\n\nWhat it is: CVE-2023-0872 is a high-severity vulnerability in The OpenNMS Group Horizon, published on 14 Aug 2023. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-0872 exists.\n\nAffected packages and fixed versions:\n- org.opennms:opennms-webapp-rest (Maven): affected from 31.0.8; fixed in 32.0.2\n- org.opennms:opennms-webapp-rest (Maven): affected from 31.0.8; fixed in 32.0.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-0872/ (Markdown: https://insights.sbomify.com/CVE-2023-0872/index.md)","id":"CVE-2023-0872","markdown":"https://insights.sbomify.com/CVE-2023-0872/index.md","name":"CVE-2023-0872","record":{"aliases":["GHSA-w5gq-xrrp-3fxf"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["privilege_escalation"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"OpenNMS Horizon","requires_auth":"low_privilege","summary":"Attackers with ROLE_REST can escalate to ROLE_ADMIN via the users endpoint, requiring an upgrade to secure the network monitoring platform.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"OpenNMS","cpe":[{"product":"horizon","vendor":"opennms"},{"product":"meridian","vendor":"opennms"}],"cvss":{"score":8.2,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:C/C:L/I:H/A:L","version":"3.1"},"cwes":[{"id":"CWE-269","name":"Improper Privilege Management"}],"description":"The Horizon REST API includes a users endpoint in OpenMNS Horizon 31.0.8 and versions earlier than 32.0.2 on multiple platforms is vulnerable to elevation of privilege. The solution is to upgrade to Meridian 2023.1.6, 2022.1.19, 2021.1.30, 2020.1.38 or Horizon 32.0.2 or newer. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet.\n\nOpenNMS thanks Erik Wynter for reporting this issue.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":"2023-07-01","github_poc":0,"max_poc_stars":null,"metasploit":1,"nuclei":0,"refs":[{"date":"2023-07-01","kind":"metasploit","ref":"exploit/linux/http/opennms_horizon_authenticated_rce","stars":null,"title":"OpenNMS Horizon Authenticated RCE"}],"tier":"weaponised"},"has_fix":true,"headline":"ROLE_REST can be used to escalate to ROLE_ADMIN via /rest/users","id":"CVE-2023-0872","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"privilege_escalation","year":"2023"},"n_packages":2,"n_references":2,"next":{"headline":"Kanban Boards for WordPress \u003c 2.5.21 - Admin+ Stored XSS","id":"CVE-2023-0873"},"packages":[{"ecosystem":"Maven","fixed":["32.0.2"],"introduced":["31.0.8"],"last_affected":[],"package":"org.opennms:opennms-webapp-rest","purl":null,"source":"GHSA-w5gq-xrrp-3fxf"},{"ecosystem":"Maven","fixed":["32.0.2"],"introduced":["31.0.8"],"last_affected":[],"package":"org.opennms:opennms-webapp-rest","purl":"pkg:maven/org.opennms/opennms-webapp-rest","source":"GHSA-w5gq-xrrp-3fxf"}],"prev":{"headline":"An XML External Entity injection vulnerability","id":"CVE-2023-0871"},"products":["Horizon","Meridian"],"published":"2023-08-14","related":[{"cvss_score":8.8,"headline":"Cross-Site Request Forgery in OpenNMS Horizon","id":"CVE-2021-25931","kev_date_added":null,"published":"2021-05-20"},{"cvss_score":8.8,"headline":"OpenNMS Horizon RCE via JEXL2 expression","id":"CVE-2021-3396","kev_date_added":null,"published":"2021-02-17"},{"cvss_score":8.1,"headline":"Form Can Be Manipulated with Cross-Site Request Forgery (CSRF)","id":"CVE-2023-0870","kev_date_added":null,"published":"2023-03-22"},{"cvss_score":8.1,"headline":"SQL injection in n/a","id":"CVE-2020-11886","kev_date_added":null,"published":"2020-04-17"},{"cvss_score":7.1,"headline":"Disable BeanShell Interpreter Remote Server Mode","id":"CVE-2023-40313","kev_date_added":null,"published":"2023-08-17"},{"cvss_score":6.8,"headline":"Plaintext Password Present in the Web logs","id":"CVE-2023-0815","kev_date_added":null,"published":"2023-02-23"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"BSD-3-Clause","name":"Metasploit"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-10-03","vendors":["The OpenNMS Group"]},"summary":"Attackers with ROLE_REST can escalate to ROLE_ADMIN via the users endpoint, requiring an upgrade to secure the network monitoring platform.","url":"https://insights.sbomify.com/CVE-2023-0872/"}