# CVE-2023-0872: ROLE_REST can be used to escalate to ROLE_ADMIN via /rest/users

> Attackers with ROLE_REST can escalate to ROLE_ADMIN via the users endpoint, requiring an upgrade to secure the network monitoring platform.

- **Severity:** High 8.2 (`CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:C/C:L/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Aug 2023
- **Updated:** 3 Oct 2024
- **Also known as:** GHSA-w5gq-xrrp-3fxf

## What is CVE-2023-0872?

CVE-2023-0872 is a high-severity vulnerability in The OpenNMS Group Horizon, published on 14 Aug 2023. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

The Horizon REST API includes a users endpoint in OpenMNS Horizon 31.0.8 and versions earlier than 32.0.2 on multiple platforms is vulnerable to elevation of privilege. The solution is to upgrade to Meridian 2023.1.6, 2022.1.19, 2021.1.30, 2020.1.38 or Horizon 32.0.2 or newer. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet.

OpenNMS thanks Erik Wynter for reporting this issue.

Weakness: CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2023-0872?

2 open source packages ship an affected version, including org.opennms:opennms-webapp-rest. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.opennms:opennms-webapp-rest` | Maven | From 31.0.8 | 32.0.2 |
| `org.opennms:opennms-webapp-rest` | Maven | From 31.0.8 | 32.0.2 |

Products: Opennms Horizon, Opennms Meridian.

## How do I fix CVE-2023-0872?

Upgrade org.opennms:opennms-webapp-rest to 32.0.2 or later.

## Is CVE-2023-0872 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-0872 exists.

Public exploit code:

- OpenNMS Horizon Authenticated RCE (metasploit)

## Other vulnerabilities in The OpenNMS Group Horizon

- [CVE-2021-25931](https://insights.sbomify.com/CVE-2021-25931/): Cross-Site Request Forgery in OpenNMS Horizon (high 8.8)
- [CVE-2021-3396](https://insights.sbomify.com/CVE-2021-3396/): OpenNMS Horizon RCE via JEXL2 expression (high 8.8)
- [CVE-2023-0870](https://insights.sbomify.com/CVE-2023-0870/): Form Can Be Manipulated with Cross-Site Request Forgery (CSRF) (high 8.1)
- [CVE-2020-11886](https://insights.sbomify.com/CVE-2020-11886/): SQL injection in n/a (high 8.1)
- [CVE-2023-40313](https://insights.sbomify.com/CVE-2023-40313/): Disable BeanShell Interpreter Remote Server Mode (high 7.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-0872 and fix it if it is affected.

What it is: CVE-2023-0872 is a high-severity vulnerability in The OpenNMS Group Horizon, published on 14 Aug 2023. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-0872 exists.

Affected packages and fixed versions:
- org.opennms:opennms-webapp-rest (Maven): affected from 31.0.8; fixed in 32.0.2
- org.opennms:opennms-webapp-rest (Maven): affected from 31.0.8; fixed in 32.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-0872/ (Markdown: https://insights.sbomify.com/CVE-2023-0872/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-0872
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-0872
- OSV: https://osv.dev/vulnerability/CVE-2023-0872

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-0872/
Summaries are generated and may contain mistakes; the official description above is the record.
