CVE-2023-0921 Allocation of Resources Without Limits or Throttling in GitLab

Medium 4.3 Published Updated

An authenticated attacker can cause CPU saturation and denial of service by creating large issue descriptions via GraphQL in GitLab.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-0921?

CVE-2023-0921 is a medium-severity denial of service vulnerability in Gitlab Gitlab, published on 6 Jun 2023. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

A lack of length validation in GitLab CE/EE affecting all versions from 8.3 before 15.10.8, 15.11 before 15.11.7, and 16.0 before 16.0.2 allows an authenticated attacker to create a large Issue description via GraphQL which, when repeatedly requested, saturates CPU usage.

Weakness: CWE-770

Which versions are affected by CVE-2023-0921?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 8.3.015.10.8, 15.11.7, 16.0.2

Products include Gitlab Gitlab.

How do I fix CVE-2023-0921?

Upgrade gitlab to a fixed version for your release line: 15.10.8, 15.11.7 or 16.0.2.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2023-0921 being exploited?

There is no known exploitation of CVE-2023-0921 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2023-0921, GHSA-p96p-59v7-xxp6, UBUNTU-CVE-2023-0921.

Is CVE-2023-0921 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free