# CVE-2023-1000: cyanomiko dcnnt-py Notification notifications.py main command injection


- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 27 Apr 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-8p42-7597-p2f6, PYSEC-2026-1293

## What is CVE-2023-1000?

CVE-2023-1000 is a medium-severity vulnerability in cyanomiko dcnnt-py, published on 27 Apr 2024. 

### Official description

A vulnerability was found in cyanomiko dcnnt-py up to 0.9.0. It has been classified as critical. Affected is the function main of the file dcnnt/plugins/notifications.py of the component Notification Handler. The manipulation leads to command injection. It is possible to launch the attack remotely. Upgrading to version 0.9.1 is able to address this issue. The patch is identified as b4021d784a97e25151a5353aa763a741e9a148f5. It is recommended to upgrade the affected component. VDB-262230 is the identifier assigned to this vulnerability.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2023-1000?

3 open source packages ship an affected version, including dcnnt.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dcnnt` | PyPI | All versions | 0.9.1 |
| `dcnnt` | PyPI | All versions | 0.9.1 |
| `dcnnt` | PyPI | All versions | 0.9.1 |

## How do I fix CVE-2023-1000?

Upgrade dcnnt to 0.9.1 or later.

## Is CVE-2023-1000 being exploited?

There is no known exploitation of CVE-2023-1000 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-1000 and fix it if it is affected.

What it is: CVE-2023-1000 is a medium-severity vulnerability in cyanomiko dcnnt-py, published on 27 Apr 2024. 
Exploitation: There is no known exploitation of CVE-2023-1000 in the wild and no public exploit code.

Affected packages and fixed versions:
- dcnnt (PyPI): affected all versions; fixed in 0.9.1
- dcnnt (PyPI): affected all versions; fixed in 0.9.1
- dcnnt (PyPI): affected all versions; fixed in 0.9.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-1000/ (Markdown: https://insights.sbomify.com/CVE-2023-1000/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-1000
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-1000
- OSV: https://osv.dev/vulnerability/CVE-2023-1000

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-1000/
Summaries are generated and may contain mistakes; the official description above is the record.
