CVE-2023-1001 xuliangzhan vxe-table vxe-textarea textarea.js export cross site scripting

Medium 5.3 Published Updated

An attacker can inject malicious scripts via the textarea export function in vxe-table, potentially executing code in the victim's browser.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-1001?

CVE-2023-1001 is a medium-severity cross-site scripting vulnerability in xuliangzhan vxe-table, published on 24 May 2024. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

A vulnerability, which was classified as problematic, has been found in xuliangzhan vxe-table up to 3.7.9. This issue affects the function export of the file packages/textarea/src/textarea.js of the component vxe-textarea. The manipulation of the argument inputValue leads to cross site scripting. The attack may be initiated remotely. Upgrading to version 3.7.10 is able to address this issue. The patch is named d70b0e089740b65a22c89c106ebc4627ac48a22d. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-266123.

Weakness: CWE-79

Which versions are affected by CVE-2023-1001?

2 open source packages ship an affected version, including vxe-table.

PackageAffectedFixed in
vxe-table npmAll versions3.7.10
vxe-table npmAll versions3.7.10

How do I fix CVE-2023-1001?

Upgrade vxe-table to 3.7.10 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2023-1001 being exploited?

There is no known exploitation of CVE-2023-1001 in the wild and no public exploit code.

Sources

Also known as GHSA-2qjp-fg8c-g878.

Is CVE-2023-1001 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free