{"answers":{"affected":"2 open source packages ship an affected version, including vxe-table.","exploited":"There is no known exploitation of CVE-2023-1001 in the wild and no public exploit code.","fix":"Upgrade vxe-table to 3.7.10 or later.","what":"CVE-2023-1001 is a medium-severity cross-site scripting vulnerability in xuliangzhan vxe-table, published on 24 May 2024. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-1001 and fix it if it is affected.\n\nWhat it is: CVE-2023-1001 is a medium-severity cross-site scripting vulnerability in xuliangzhan vxe-table, published on 24 May 2024. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-1001 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- vxe-table (npm): affected all versions; fixed in 3.7.10\n- vxe-table (npm): affected all versions; fixed in 3.7.10\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-1001/ (Markdown: https://insights.sbomify.com/CVE-2023-1001/index.md)","id":"CVE-2023-1001","markdown":"https://insights.sbomify.com/CVE-2023-1001/index.md","name":"CVE-2023-1001","record":{"aliases":["GHSA-2qjp-fg8c-g878"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Vue table library","requires_auth":"low_privilege","summary":"An attacker can inject malicious scripts via the textarea export function in vxe-table, potentially executing code in the victim's browser.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A vulnerability, which was classified as problematic, has been found in xuliangzhan vxe-table up to 3.7.9. This issue affects the function export of the file packages/textarea/src/textarea.js of the component vxe-textarea. The manipulation of the argument inputValue leads to cross site scripting. The attack may be initiated remotely. Upgrading to version 3.7.10 is able to address this issue. The patch is named d70b0e089740b65a22c89c106ebc4627ac48a22d. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-266123.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"xuliangzhan vxe-table vxe-textarea textarea.js export cross site scripting","id":"CVE-2023-1001","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2023"},"n_packages":2,"n_references":5,"next":{"headline":"MuYuCMS index.php path traversal","id":"CVE-2023-1002"},"packages":[{"ecosystem":"npm","fixed":["3.7.10"],"introduced":["0"],"last_affected":[],"package":"vxe-table","purl":null,"source":"GHSA-2qjp-fg8c-g878"},{"ecosystem":"npm","fixed":["3.7.10"],"introduced":["0"],"last_affected":[],"package":"vxe-table","purl":"pkg:npm/vxe-table","source":"GHSA-2qjp-fg8c-g878"}],"prev":{"headline":"cyanomiko dcnnt-py Notification notifications.py main command injection","id":"CVE-2023-1000"},"products":["vxe-table"],"published":"2024-05-24","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-02","vendors":["xuliangzhan"]},"summary":"An attacker can inject malicious scripts via the textarea export function in vxe-table, potentially executing code in the victim's browser.","url":"https://insights.sbomify.com/CVE-2023-1001/"}