# CVE-2023-1001: xuliangzhan vxe-table vxe-textarea textarea.js export cross site scripting

> An attacker can inject malicious scripts via the textarea export function in vxe-table, potentially executing code in the victim's browser.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 May 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-2qjp-fg8c-g878

## What is CVE-2023-1001?

CVE-2023-1001 is a medium-severity cross-site scripting vulnerability in xuliangzhan vxe-table, published on 24 May 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A vulnerability, which was classified as problematic, has been found in xuliangzhan vxe-table up to 3.7.9. This issue affects the function export of the file packages/textarea/src/textarea.js of the component vxe-textarea. The manipulation of the argument inputValue leads to cross site scripting. The attack may be initiated remotely. Upgrading to version 3.7.10 is able to address this issue. The patch is named d70b0e089740b65a22c89c106ebc4627ac48a22d. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-266123.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-1001?

2 open source packages ship an affected version, including vxe-table.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vxe-table` | npm | All versions | 3.7.10 |
| `vxe-table` | npm | All versions | 3.7.10 |

## How do I fix CVE-2023-1001?

Upgrade vxe-table to 3.7.10 or later.

## Is CVE-2023-1001 being exploited?

There is no known exploitation of CVE-2023-1001 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-1001 and fix it if it is affected.

What it is: CVE-2023-1001 is a medium-severity cross-site scripting vulnerability in xuliangzhan vxe-table, published on 24 May 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-1001 in the wild and no public exploit code.

Affected packages and fixed versions:
- vxe-table (npm): affected all versions; fixed in 3.7.10
- vxe-table (npm): affected all versions; fixed in 3.7.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-1001/ (Markdown: https://insights.sbomify.com/CVE-2023-1001/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-1001
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-1001
- OSV: https://osv.dev/vulnerability/CVE-2023-1001

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-1001/
Summaries are generated and may contain mistakes; the official description above is the record.
