{"answers":{"affected":"2 open source packages ship an affected version, including really-simple-plugins/complianz-gdpr. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-1069 exists.","fix":"Upgrade really-simple-plugins/complianz-gdpr to 6.4.2 or later.","what":"CVE-2023-1069 is a medium-severity cross-site scripting vulnerability in Unknown Complianz, published on 27 Mar 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-1069 and fix it if it is affected.\n\nWhat it is: CVE-2023-1069 is a medium-severity cross-site scripting vulnerability in Unknown Complianz, published on 27 Mar 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-1069 exists.\n\nAffected packages and fixed versions:\n- really-simple-plugins/complianz-gdpr (Packagist): affected all versions; fixed in 6.4.2\n- really-simple-plugins/complianz-gdpr (Packagist): affected all versions; fixed in 6.4.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-1069/ (Markdown: https://insights.sbomify.com/CVE-2023-1069/index.md)","id":"CVE-2023-1069","markdown":"https://insights.sbomify.com/CVE-2023-1069/index.md","name":"CVE-2023-1069","record":{"aliases":["GHSA-7j4m-f87g-5r9r"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"low_privilege","summary":"Contributors can inject malicious scripts via shortcode attributes in the Complianz plugin, leading to stored XSS attacks on site visitors.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"WPScan","cpe":[{"product":"complianz","vendor":"really-simple-plugins"}],"cvss":{"score":5.4,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[],"description":"The Complianz WordPress plugin before 6.4.2, Complianz Premium WordPress plugin before 6.4.2 do not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Complianz - GDPR/CCPA Cookie Consent \u003c 6.4.2 - Contributor+ Stored XSS","id":"CVE-2023-1069","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2023"},"n_packages":2,"n_references":1,"next":{"headline":"External Control of File Name or Path in nilsteampassnet/teampass","id":"CVE-2023-1070"},"packages":[{"ecosystem":"Packagist","fixed":["6.4.2"],"introduced":["0"],"last_affected":[],"package":"really-simple-plugins/complianz-gdpr","purl":null,"source":"GHSA-7j4m-f87g-5r9r"},{"ecosystem":"Packagist","fixed":["6.4.2"],"introduced":["0"],"last_affected":[],"package":"really-simple-plugins/complianz-gdpr","purl":"pkg:composer/really-simple-plugins/complianz-gdpr","source":"GHSA-7j4m-f87g-5r9r"}],"prev":{"headline":"Download Read More Excerpt Link \u003c= 1.6.0 - Cross-Site Request Forgery to Settings Update","id":"CVE-2023-1068"},"products":["Complianz","Complianz Premium"],"published":"2023-03-27","related":[{"cvss_score":8.8,"headline":"Complianz (Free \u003c 6.3.4, Premium \u003c 6.3.6) - Translator SQLi","id":"CVE-2022-3494","kev_date_added":null,"published":"2022-11-07"},{"cvss_score":7.1,"headline":"Cross-site request forgery in Complianz","id":"CVE-2023-33333","kev_date_added":null,"published":"2023-11-30"},{"cvss_score":6.5,"headline":"WordPress Complianz and Complianz Premium plugins - Cross Site Request Forgery (CSRF)","id":"CVE-2023-34030","kev_date_added":null,"published":"2023-11-30"},{"cvss_score":6.1,"headline":"Complianz - GDPR/CCPA Cookie Consent \u003c 6.0.0 - Reflected Cross-Site Scripting","id":"CVE-2022-0193","kev_date_added":null,"published":"2022-02-14"},{"cvss_score":4.4,"headline":"Complianz | GDPR/CCPA Cookie Consent \u003c= 6.5.5 - Authenticated(Administrator+) Stored Cross-site Scripting via settings","id":"CVE-2023-6498","kev_date_added":null,"published":"2024-01-04"},{"cvss_score":4.3,"headline":"Complianz – GDPR/CCPA Cookie Consent \u003c= 6.5.6 - Cross-Site Request Forgery to Data Request Deletion","id":"CVE-2024-1592","kev_date_added":null,"published":"2024-03-02"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-02-18","vendors":["Unknown"]},"summary":"Contributors can inject malicious scripts via shortcode attributes in the Complianz plugin, leading to stored XSS attacks on site visitors.","url":"https://insights.sbomify.com/CVE-2023-1069/"}