# CVE-2023-1069: Complianz - GDPR/CCPA Cookie Consent < 6.4.2 - Contributor+ Stored XSS

> Contributors can inject malicious scripts via shortcode attributes in the Complianz plugin, leading to stored XSS attacks on site visitors.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 27 Mar 2023
- **Updated:** 18 Feb 2025
- **Also known as:** GHSA-7j4m-f87g-5r9r

## What is CVE-2023-1069?

CVE-2023-1069 is a medium-severity cross-site scripting vulnerability in Unknown Complianz, published on 27 Mar 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

The Complianz WordPress plugin before 6.4.2, Complianz Premium WordPress plugin before 6.4.2 do not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks

## Which versions are affected by CVE-2023-1069?

2 open source packages ship an affected version, including really-simple-plugins/complianz-gdpr. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `really-simple-plugins/complianz-gdpr` | Packagist | All versions | 6.4.2 |
| `really-simple-plugins/complianz-gdpr` | Packagist | All versions | 6.4.2 |

Products: Really-Simple-Plugins Complianz.

## How do I fix CVE-2023-1069?

Upgrade really-simple-plugins/complianz-gdpr to 6.4.2 or later.

## Is CVE-2023-1069 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-1069 exists.

## Other vulnerabilities in Unknown Complianz

- [CVE-2022-3494](https://insights.sbomify.com/CVE-2022-3494/): Complianz (Free < 6.3.4, Premium < 6.3.6) - Translator SQLi (high 8.8)
- [CVE-2023-33333](https://insights.sbomify.com/CVE-2023-33333/): Cross-site request forgery in Complianz (high 7.1)
- [CVE-2023-34030](https://insights.sbomify.com/CVE-2023-34030/): WordPress Complianz and Complianz Premium plugins - Cross Site Request Forgery (CSRF) (medium 6.5)
- [CVE-2022-0193](https://insights.sbomify.com/CVE-2022-0193/): Complianz - GDPR/CCPA Cookie Consent < 6.0.0 - Reflected Cross-Site Scripting (medium 6.1)
- [CVE-2023-6498](https://insights.sbomify.com/CVE-2023-6498/): Complianz | GDPR/CCPA Cookie Consent <= 6.5.5 - Authenticated(Administrator+) Stored Cross-site Scripting via settings (medium 4.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-1069 and fix it if it is affected.

What it is: CVE-2023-1069 is a medium-severity cross-site scripting vulnerability in Unknown Complianz, published on 27 Mar 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-1069 exists.

Affected packages and fixed versions:
- really-simple-plugins/complianz-gdpr (Packagist): affected all versions; fixed in 6.4.2
- really-simple-plugins/complianz-gdpr (Packagist): affected all versions; fixed in 6.4.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-1069/ (Markdown: https://insights.sbomify.com/CVE-2023-1069/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-1069
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-1069
- OSV: https://osv.dev/vulnerability/CVE-2023-1069

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-1069/
Summaries are generated and may contain mistakes; the official description above is the record.
