CVE-2023-1071 Missing authorization in GitLab

Low 3.1 Published Updated

An unauthorized user can remove issues from epics due to improper permission checks in GitLab.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-1071?

CVE-2023-1071 is a low-severity missing authorization vulnerability in Gitlab Gitlab, published on 5 Apr 2023. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An issue has been discovered in GitLab affecting all versions from 15.5 before 15.8.5, all versions starting from 15.9 before 15.9.4, all versions starting from 15.10 before 15.10.1. Due to improper permissions checks it was possible for an unauthorised user to remove an issue from an epic.

Weakness: CWE-863, CWE-400

Which versions are affected by CVE-2023-1071?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 15.5.015.8.5, 15.9.4, 15.10.1

Products include Gitlab Gitlab.

How do I fix CVE-2023-1071?

Upgrade gitlab to a fixed version for your release line: 15.8.5, 15.9.4 or 15.10.1.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2023-1071 being exploited?

There is no known exploitation of CVE-2023-1071 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2023-1071, GHSA-rrjx-38j3-wx7p, UBUNTU-CVE-2023-1071.

Is CVE-2023-1071 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free