CVE-2023-1072 Denial of service in GitLab

Medium 4.3 Published Updated

Attackers can cause resource depletion in GitLab by exploiting improper filtering on commit detail requests, leading to denial of service.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-1072?

CVE-2023-1072 is a medium-severity denial of service vulnerability in Gitlab Gitlab, published on 9 Mar 2023. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An issue has been discovered in GitLab affecting all versions starting from 9.0 before 15.7.8, all versions starting from 15.8 before 15.8.4, all versions starting from 15.9 before 15.9.2. It was possible to trigger a resource depletion attack due to improper filtering for number of requests to read commits details.

Weakness: CWE-400

Which versions are affected by CVE-2023-1072?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 9.0.015.7.8, 15.8.4, 15.9.2

Products include Gitlab Gitlab.

How do I fix CVE-2023-1072?

Upgrade gitlab to a fixed version for your release line: 15.7.8, 15.8.4 or 15.9.2.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2023-1072 being exploited?

There is no known exploitation of CVE-2023-1072 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2023-1072, GHSA-jp4w-5rwv-5wmh, UBUNTU-CVE-2023-1072.

Is CVE-2023-1072 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free