CVE-2023-1167 Missing authorization in GitLab
An attacker can access security reports in merge requests without proper authorization, exposing sensitive security data.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-1167?
CVE-2023-1167 is a medium-severity missing authorization vulnerability in Gitlab Gitlab, published on 5 Apr 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Improper authorization in Gitlab EE affecting all versions from 12.3.0 before 15.8.5, all versions starting from 15.9 before 15.9.4, all versions starting from 15.10 before 15.10.1 allows an unauthorized access to security reports in MR.
Which versions are affected by CVE-2023-1167?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 12.3.0 | 15.8.5, 15.9.4, 15.10.1 |
Products include Gitlab Gitlab.
How do I fix CVE-2023-1167?
Upgrade gitlab to a fixed version for your release line: 15.8.5, 15.9.4 or 15.10.1.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2023-1167 being exploited?
There is no known exploitation of CVE-2023-1167 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2023-1167, GHSA-7g53-7whp-2hm3.