CVE-2023-1178 Code injection in GitLab

Medium 5.7 Published Updated

Attackers can compromise file integrity and potentially execute code by manipulating Git references in tags or releases.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2023-1178?

CVE-2023-1178 is a medium-severity code injection vulnerability in Gitlab Gitlab, published on 3 May 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

An issue has been discovered in GitLab CE/EE affecting all versions from 8.6 before 15.9.6, all versions starting from 15.10 before 15.10.5, all versions starting from 15.11 before 15.11.1. File integrity may be compromised when source code or installation packages are pulled from a tag or from a release containing a ref to another commit.

Weakness: CWE-94

Which versions are affected by CVE-2023-1178?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 8.6.015.9.6, 15.10.5, 15.11.1

Products include Gitlab Gitlab.

How do I fix CVE-2023-1178?

Upgrade gitlab to a fixed version for your release line: 15.9.6, 15.10.5 or 15.11.1.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2023-1178 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-1178 exists.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2023-1178, GHSA-2m6q-rj94-6952, UBUNTU-CVE-2023-1178.

Is CVE-2023-1178 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free