CVE-2023-1210 Generation of Error Message Containing Sensitive Information in GitLab

Low 3.1 Published Updated

An attacker can leak user email addresses via error messages in GitLab groups restricted by email domain, requiring specific group settings.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-1210?

CVE-2023-1210 is a low-severity vulnerability in Gitlab Gitlab, published on 1 Aug 2023. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An issue has been discovered in GitLab affecting all versions starting from 12.9 before 16.0.8, all versions starting from 16.1 before 16.1.3, all versions starting from 16.2 before 16.2.2. It was possible to leak a user's email via an error message for groups that restrict membership by email domain.

Weakness: CWE-209

Which versions are affected by CVE-2023-1210?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 12.9.016.0.8, 16.1.3, 16.2.2

Products include Gitlab Gitlab.

How do I fix CVE-2023-1210?

Upgrade gitlab to a fixed version for your release line: 16.0.8, 16.1.3 or 16.2.2.

Is CVE-2023-1210 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-1210 exists.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2023-1210, GHSA-96gj-7pcm-7895, UBUNTU-CVE-2023-1210.

Is CVE-2023-1210 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free