# CVE-2023-1239: Cross-site Scripting (XSS) - Reflected in answerdev/answer

> Attackers can execute arbitrary scripts in victim browsers via reflected XSS in the Answer Q&A platform, potentially leading to session hijacking.

- **Severity:** Medium 6.0 (`CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Mar 2023
- **Updated:** 6 Mar 2025
- **Also known as:** GHSA-vxhr-p2vp-7gf8, GO-2023-1620

## What is CVE-2023-1239?

CVE-2023-1239 is a medium-severity cross-site scripting vulnerability in answerdev/answer, published on 7 Mar 2023. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Cross-site Scripting (XSS) - Reflected in GitHub repository answerdev/answer prior to 1.0.6.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-1239?

3 open source packages ship an affected version, including github.com/answerdev/answer. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/answerdev/answer` | Go | All versions | 1.0.6 |
| `github.com/answerdev/answer` | Go | All versions | 1.0.6 |
| `github.com/answerdev/answer` | Go | All versions | 1.0.6 |

Products: Answer Answer.

## How do I fix CVE-2023-1239?

Upgrade github.com/answerdev/answer to 1.0.6 or later.

## Is CVE-2023-1239 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-1239 exists.

## Other vulnerabilities in answerdev/answer

- [CVE-2023-0744](https://insights.sbomify.com/CVE-2023-0744/): Improper Access Control in answerdev/answer (critical 9.8)
- [CVE-2023-1244](https://insights.sbomify.com/CVE-2023-1244/): Cross-site Scripting (XSS) - Stored in answerdev/answer (critical 9.3)
- [CVE-2023-4125](https://insights.sbomify.com/CVE-2023-4125/): Weak Password Requirements in answerdev/answer (high 8.8)
- [CVE-2023-1241](https://insights.sbomify.com/CVE-2023-1241/): Cross-site Scripting (XSS) - Stored in answerdev/answer (high 8.8)
- [CVE-2023-4815](https://insights.sbomify.com/CVE-2023-4815/): Missing Authentication for Critical Function in answerdev/answer (high 8.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-1239 and fix it if it is affected.

What it is: CVE-2023-1239 is a medium-severity cross-site scripting vulnerability in answerdev/answer, published on 7 Mar 2023. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-1239 exists.

Affected packages and fixed versions:
- github.com/answerdev/answer (Go): affected all versions; fixed in 1.0.6
- github.com/answerdev/answer (Go): affected all versions; fixed in 1.0.6
- github.com/answerdev/answer (Go): affected all versions; fixed in 1.0.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-1239/ (Markdown: https://insights.sbomify.com/CVE-2023-1239/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-1239
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-1239
- OSV: https://osv.dev/vulnerability/CVE-2023-1239

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-1239/
Summaries are generated and may contain mistakes; the official description above is the record.
