CVE-2023-1296 Nomad ACLs Can Not Deny Access to Workload's Own Variables

Low 2.7 Published Updated

Attackers can bypass ACL deny policies to read workload variables in HashiCorp Nomad, exposing sensitive configuration data.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-1296?

CVE-2023-1296 is a low-severity missing authorization vulnerability in HashiCorp Nomad, published on 14 Mar 2023. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

HashiCorp Nomad and Nomad Enterprise 1.4.0 up to 1.5.0 did not correctly enforce deny policies applied to a workload’s variables. Fixed in 1.4.6 and 1.5.1.

Weakness: CWE-862, CWE-682

Which versions are affected by CVE-2023-1296?

5 open source packages ship an affected version, including github.com/hashicorp/nomad. It affects 1 product.

PackageAffectedFixed in
github.com/hashicorp/nomad GoFrom 1.4.01.4.6, 1.5.1
github.com/hashicorp/nomad GoFrom 1.4.01.4.6
github.com/hashicorp/nomad GoFrom 1.4.01.4.6
github.com/hashicorp/nomad GoFrom 1.5.01.5.1
github.com/hashicorp/nomad GoFrom 1.5.01.5.1

Products include Hashicorp Nomad.

How do I fix CVE-2023-1296?

Upgrade github.com/hashicorp/nomad to a fixed version for your release line: 1.4.6 or 1.5.1.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2023-1296 being exploited?

There is no known exploitation of CVE-2023-1296 in the wild and no public exploit code.

Sources

Also known as GHSA-hhvx-8755-4cvw, GO-2023-1899, UBUNTU-CVE-2023-1296.

Is CVE-2023-1296 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free