CVE-2023-1314 Local Privilege Escalation Vulnerability in cloudflared's Installer

High 7.5 Published Updated

Local attackers can escalate privileges by exploiting a world-writable directory in the Windows installer to delete or replace system files.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2023-1314?

CVE-2023-1314 is a high-severity vulnerability in cloudflared, published on 21 Mar 2023. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

A vulnerability has been discovered in cloudflared's installer (<= 2023.3.0) for Windows 32-bits devices that allows a local attacker with no administrative permissions to escalate their privileges on the affected device. This vulnerability exists because the MSI installer used by cloudflared relied on a world-writable directory.

An attacker with local access to the device (without Administrator rights) can use symbolic links to trick the MSI installer into deleting files in locations that the attacker would otherwise have no access to. By creating a symlink from the world-writable directory to the target file, the attacker can manipulate the MSI installer's repair functionality to delete the target file during the repair process.

Exploitation of this vulnerability could allow an attacker to delete important system files or replace them with malicious files, potentially leading to the affected device being compromised.

The cloudflared client itself is not affected by this vulnerability, only the installer for 32-bit Windows devices.

Weakness: CWE-59

Which versions are affected by CVE-2023-1314?

3 open source packages ship an affected version, including github.com/cloudflare/cloudflared. It affects 1 product.

PackageAffectedFixed in
github.com/cloudflare/cloudflared GoAll versions0.0.0-20230313153246-f686da832f85
github.com/cloudflare/cloudflared GoAll versions0.0.0-20230313153246-f686da832f85
github.com/cloudflare/cloudflared GoAll versions0.0.0-20230313153246-f686da832f85

Products include Cloudflare Cloudflared.

How do I fix CVE-2023-1314?

Upgrade github.com/cloudflare/cloudflared to 0.0.0-20230313153246-f686da832f85 or later.

Is CVE-2023-1314 being exploited?

There is no known exploitation of CVE-2023-1314 in the wild and no public exploit code.

Sources

Also known as GHSA-7mjv-x3jf-545x, GO-2023-1652.

Is CVE-2023-1314 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free