# CVE-2023-1367: Code Injection in alextselegidis/easyappointments


- **Severity:** Medium 6.0 (`CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 13 Mar 2023
- **Updated:** 27 Feb 2025
- **Also known as:** GHSA-9qvw-fhj2-xqmv

## What is CVE-2023-1367?

CVE-2023-1367 is a medium-severity vulnerability in alextselegidis/easyappointments, published on 13 Mar 2023. 

### Official description

Code Injection in GitHub repository alextselegidis/easyappointments prior to 1.5.0.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2023-1367?

2 open source packages ship an affected version, including alextselegidis/easyappointments. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `alextselegidis/easyappointments` | Packagist | All versions | 1.5.0 |
| `alextselegidis/easyappointments` | Packagist | All versions | 1.5.0 |

Products: Easyappointments Easyappointments.

## How do I fix CVE-2023-1367?

Upgrade alextselegidis/easyappointments to 1.5.0 or later.

## Is CVE-2023-1367 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-1367 exists.

## Other vulnerabilities in alextselegidis/easyappointments

- [CVE-2023-3287](https://insights.sbomify.com/CVE-2023-3287/): A BOLA vulnerability in POST /admins in EasyAppointments < 1.5.0 (critical 9.9)
- [CVE-2023-38048](https://insights.sbomify.com/CVE-2023-38048/): A BOLA vulnerability in GET, PUT, DELETE /providers/{providerId} in EasyAppointments < 1.5.0 (critical 9.9)
- [CVE-2023-38049](https://insights.sbomify.com/CVE-2023-38049/): A BOLA vulnerability in GET, PUT, DELETE /appointments/{appointmentId} in EasyAppointments < 1.5.0 (critical 9.9)
- [CVE-2023-38051](https://insights.sbomify.com/CVE-2023-38051/): A BOLA vulnerability in GET, PUT, DELETE /secretaries/{secretaryId} in EasyAppointments < 1.5.0 (critical 9.9)
- [CVE-2023-38052](https://insights.sbomify.com/CVE-2023-38052/): A BOLA vulnerability in GET, PUT, DELETE /admins/{adminId} in EasyAppointments < 1.5.0 (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-1367 and fix it if it is affected.

What it is: CVE-2023-1367 is a medium-severity vulnerability in alextselegidis/easyappointments, published on 13 Mar 2023. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-1367 exists.

Affected packages and fixed versions:
- alextselegidis/easyappointments (Packagist): affected all versions; fixed in 1.5.0
- alextselegidis/easyappointments (Packagist): affected all versions; fixed in 1.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-1367/ (Markdown: https://insights.sbomify.com/CVE-2023-1367/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-1367
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-1367
- OSV: https://osv.dev/vulnerability/CVE-2023-1367

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-1367/
Summaries are generated and may contain mistakes; the official description above is the record.
