CVE-2023-1402 Moodle: course participation report shows roles the user should not see
Attackers can view unauthorized role information in the course participation report, leading to sensitive data disclosure.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-1402?
CVE-2023-1402 is a medium-severity vulnerability in Moodle Moodle, published on 23 Mar 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
The course participation report required additional checks to prevent roles being displayed which the user did not have access to view.
Which versions are affected by CVE-2023-1402?
9 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | All versions | 3.9.20 |
moodle/moodle Packagist | All versions | 3.9.20 |
moodle/moodle Packagist | From 3.11.0 | 3.11.13 |
moodle/moodle Packagist | From 3.11.0 | 3.11.13 |
moodle/moodle Packagist | From 4.0.0 | 4.0.7 |
moodle/moodle Packagist | From 4.0.0 | 4.0.7 |
3 more packages
moodle/moodle Packagist | From 4.1.0 | 4.1.2 |
moodle/moodle Packagist | From 4.1.0 | 4.1.2 |
moodle Bitnami | From 3.9.0 | 3.9.20, 3.11.13, 4.0.7, 4.1.2 |
Products include Moodle Moodle.
How do I fix CVE-2023-1402?
Upgrade moodle/moodle to a fixed version for your release line: 3.9.20, 3.11.13, 4.0.7 or 4.1.2.
Is CVE-2023-1402 being exploited?
There is no known exploitation of CVE-2023-1402 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as BIT-moodle-2023-1402, GHSA-vj5p-fp42-774p, UBUNTU-CVE-2023-1402.