CVE-2023-1417 Missing authorization in GitLab
An unauthorized user can add child epics to a victim's epic in an unrelated group, allowing unauthorized data modification.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-1417?
CVE-2023-1417 is a medium-severity missing authorization vulnerability in Gitlab Gitlab, published on 5 Apr 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
An issue has been discovered in GitLab affecting all versions starting from 15.9 before 15.9.4, all versions starting from 15.10 before 15.10.1. It was possible for an unauthorised user to add child epics linked to victim's epic in an unrelated group.
Which versions are affected by CVE-2023-1417?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 15.9.0 | 15.9.4, 15.10.1 |
Products include Gitlab Gitlab.
How do I fix CVE-2023-1417?
Upgrade gitlab to a fixed version for your release line: 15.9.4 or 15.10.1.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2023-1417 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-1417 exists.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2023-1417, GHSA-96cq-cj7w-27g2, UBUNTU-CVE-2023-1417.