# CVE-2023-1419: Debezium: script injection via connector parameter

> An attacker can inject malicious scripts via connector parameters in Debezium to view unauthorized data.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Nov 2024
- **Updated:** 18 Nov 2024
- **Also known as:** CLEANSTART-2026-XD56124, GHSA-hvw5-3mgw-7rcf

## What is CVE-2023-1419?

CVE-2023-1419 is a medium-severity code injection vulnerability in Red Hat Integration Change Data Capture, published on 17 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A script injection vulnerability was found in the Debezium database connector, where it does not properly sanitize some parameters. This flaw allows an attacker to send a malicious request to inject a parameter that may allow the viewing of unauthorized data.

Weakness: CWE-233 (Improper Handling of Parameters)

## Which versions are affected by CVE-2023-1419?

6 open source packages ship an affected version, including io.debezium:debezium-connector-mysql, io.debezium:debezium-connector-sqlserver and io.debezium:debezium-core.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.debezium:debezium-connector-mysql` | Maven | All versions | 2.3.0.Alpha1 |
| `io.debezium:debezium-connector-mysql` | Maven | All versions | 2.3.0.Alpha1 |
| `io.debezium:debezium-connector-sqlserver` | Maven | All versions | 2.3.0.Alpha1 |
| `io.debezium:debezium-connector-sqlserver` | Maven | All versions | 2.3.0.Alpha1 |
| `io.debezium:debezium-core` | Maven | All versions | 2.3.0.Alpha1 |
| `io.debezium:debezium-core` | Maven | All versions | 2.3.0.Alpha1 |

## How do I fix CVE-2023-1419?

Upgrade io.debezium:debezium-connector-mysql to 2.3.0.Alpha1 or later.

## Is CVE-2023-1419 being exploited?

There is no known exploitation of CVE-2023-1419 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-1419 and fix it if it is affected.

What it is: CVE-2023-1419 is a medium-severity code injection vulnerability in Red Hat Integration Change Data Capture, published on 17 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-1419 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.debezium:debezium-connector-mysql (Maven): affected all versions; fixed in 2.3.0.Alpha1
- io.debezium:debezium-connector-mysql (Maven): affected all versions; fixed in 2.3.0.Alpha1
- io.debezium:debezium-connector-sqlserver (Maven): affected all versions; fixed in 2.3.0.Alpha1
- io.debezium:debezium-connector-sqlserver (Maven): affected all versions; fixed in 2.3.0.Alpha1
- io.debezium:debezium-core (Maven): affected all versions; fixed in 2.3.0.Alpha1
- io.debezium:debezium-core (Maven): affected all versions; fixed in 2.3.0.Alpha1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-1419/ (Markdown: https://insights.sbomify.com/CVE-2023-1419/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-1419
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-1419
- OSV: https://osv.dev/vulnerability/CVE-2023-1419

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-1419/
Summaries are generated and may contain mistakes; the official description above is the record.
