# CVE-2023-1428: Denial-of-Service in gRPC

> Attackers can cause a denial of service in gRPC C++ implementations by sending specific malformed HTTP/2 headers that trigger an abort.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Jun 2023
- **Updated:** 26 Sep 2024
- **Also known as:** BELL-CVE-2023-1428, CLEANSTART-2026-ER15983, GHSA-6628-q6j9-w8vg, PYSEC-2026-1425, UBUNTU-CVE-2023-1428

## What is CVE-2023-1428?

CVE-2023-1428 is a high-severity denial of service vulnerability in Google gRPC, published on 9 Jun 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

There exists an vulnerability causing an abort() to be called in gRPC. 
The following headers cause gRPC's C++ implementation to abort() when called via http2:

te: x (x != trailers)

:scheme: x (x != http, https)

grpclb_client_stats: x (x == anything)

On top of sending one of those headers, a later header must be sent that gets the total header size past 8KB. We recommend upgrading past git commit 2485fa94bd8a723e5c977d55a3ce10b301b437f8 or v1.53 and above.

Weakness: CWE-617 (Reachable Assertion)

## Which versions are affected by CVE-2023-1428?

7 open source packages ship an affected version, including grpcio, io.grpc:grpc-protobuf and grpc. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `grpcio` | PyPI | From 1.51.0 | 1.53.0 |
| `grpcio` | PyPI | From 1.51.0 | 1.53.0 |
| `grpcio` | PyPI | From 1.51.0 | 1.53.0 |
| `io.grpc:grpc-protobuf` | Maven | From 1.51.0 | 1.53.0 |
| `io.grpc:grpc-protobuf` | Maven | From 1.51.0 | 1.53.0 |
| `grpc` | RubyGems | From 1.51.0 | 1.53.0 |
| `grpc` | RubyGems | From 1.51.0 | 1.53.0 |

Products: Grpc Grpc.

## How do I fix CVE-2023-1428?

Upgrade grpcio to 1.53.0 or later.

## Is CVE-2023-1428 being exploited?

There is no known exploitation of CVE-2023-1428 in the wild and no public exploit code.

## Other vulnerabilities in Google gRPC

- [CVE-2017-9431](https://insights.sbomify.com/CVE-2017-9431/): Memory corruption in n/a (critical 9.8)
- [CVE-2017-8359](https://insights.sbomify.com/CVE-2017-8359/): Use after free in n/a (critical 9.8)
- [CVE-2017-7860](https://insights.sbomify.com/CVE-2017-7860/): Memory corruption in n/a (critical 9.8)
- [CVE-2017-7861](https://insights.sbomify.com/CVE-2017-7861/): Memory corruption in n/a (critical 9.8)
- [CVE-2026-33186](https://insights.sbomify.com/CVE-2026-33186/): gRPC-Go has an authorization bypass via missing leading slash in :path (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-1428 and fix it if it is affected.

What it is: CVE-2023-1428 is a high-severity denial of service vulnerability in Google gRPC, published on 9 Jun 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-1428 in the wild and no public exploit code.

Affected packages and fixed versions:
- grpcio (PyPI): affected from 1.51.0; fixed in 1.53.0
- grpcio (PyPI): affected from 1.51.0; fixed in 1.53.0
- grpcio (PyPI): affected from 1.51.0; fixed in 1.53.0
- io.grpc:grpc-protobuf (Maven): affected from 1.51.0; fixed in 1.53.0
- io.grpc:grpc-protobuf (Maven): affected from 1.51.0; fixed in 1.53.0
- grpc (RubyGems): affected from 1.51.0; fixed in 1.53.0
- grpc (RubyGems): affected from 1.51.0; fixed in 1.53.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-1428/ (Markdown: https://insights.sbomify.com/CVE-2023-1428/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-1428
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-1428
- OSV: https://osv.dev/vulnerability/CVE-2023-1428

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-1428/
Summaries are generated and may contain mistakes; the official description above is the record.
