# CVE-2023-1436: Infinite recursion in Jettison leads to denial of service when creating a crafted JSONArray

> An attacker can cause a denial of service by triggering infinite recursion in the Jettison library when processing crafted JSON arrays.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Mar 2023
- **Updated:** 26 Feb 2025
- **Also known as:** CLEANSTART-2026-FW96675, DEBIAN-CVE-2023-1436, ECHO-c7a7-9448-f9f3, GHSA-q6g2-g7f3-rr83, OESA-2023-1963, OESA-2023-1964, OESA-2023-1966, OESA-2023-1967, OESA-2023-1968, SUSE-SU-2023:1948-1, UBUNTU-CVE-2023-1436, USN-6179-1, openSUSE-SU-2024:12871-1

## What is CVE-2023-1436?

CVE-2023-1436 is a medium-severity denial of service vulnerability in jettison, published on 16 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An infinite recursion is triggered in Jettison when constructing a JSONArray from a Collection that contains a self-reference in one of its elements. This leads to a StackOverflowError exception being thrown.

Weakness: CWE-674 (Uncontrolled Recursion)

## Which versions are affected by CVE-2023-1436?

2 open source packages ship an affected version, including org.codehaus.jettison:jettison. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.codehaus.jettison:jettison` | Maven | All versions | 1.5.4 |
| `org.codehaus.jettison:jettison` | Maven | All versions | 1.5.4 |
| `jettison` | openSUSE:Leap 15.4 | All versions | 1.5.4-150200.3.7.1 |
| `jettison` | openSUSE:Tumbleweed | All versions | 1.5.4-1.1 |

Products: Jettison Project Jettison.

## How do I fix CVE-2023-1436?

Upgrade org.codehaus.jettison:jettison to 1.5.4 or later.

## Is CVE-2023-1436 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-1436 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-1436 and fix it if it is affected.

What it is: CVE-2023-1436 is a medium-severity denial of service vulnerability in jettison, published on 16 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-1436 exists.

Affected packages and fixed versions:
- org.codehaus.jettison:jettison (Maven): affected all versions; fixed in 1.5.4
- org.codehaus.jettison:jettison (Maven): affected all versions; fixed in 1.5.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-1436/ (Markdown: https://insights.sbomify.com/CVE-2023-1436/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-1436
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-1436
- OSV: https://osv.dev/vulnerability/CVE-2023-1436

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-1436/
Summaries are generated and may contain mistakes; the official description above is the record.
