# CVE-2023-1496: Cross-site Scripting (XSS) - Reflected in imgproxy/imgproxy

> An attacker can execute arbitrary scripts in a victim's browser via reflected XSS in the imgproxy image proxy server.

- **Severity:** Medium 6.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Mar 2023
- **Updated:** 26 Feb 2025
- **Also known as:** GHSA-ch9g-x9j7-rcgp, GO-2023-1651

## What is CVE-2023-1496?

CVE-2023-1496 is a medium-severity cross-site scripting vulnerability in imgproxy/imgproxy, published on 19 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Cross-site Scripting (XSS) - Reflected in GitHub repository imgproxy/imgproxy prior to 3.14.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-1496?

5 open source packages ship an affected version, including github.com/imgproxy/imgproxy/v3, github.com/imgproxy/imgproxy and github.com/imgproxy/imgproxy/v2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/imgproxy/imgproxy/v3` | Go | All versions | 3.14.0 |
| `github.com/imgproxy/imgproxy/v3` | Go | All versions | 3.14.0 |
| `github.com/imgproxy/imgproxy/v3` | Go | All versions | 3.14.0 |
| `github.com/imgproxy/imgproxy` | Go | All versions | None |
| `github.com/imgproxy/imgproxy/v2` | Go | All versions | None |

Products: Evilmartians Imgproxy.

## How do I fix CVE-2023-1496?

Upgrade github.com/imgproxy/imgproxy/v3 to 3.14.0 or later.

## Is CVE-2023-1496 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-1496 exists.

Public exploit code:

- Imgproxy < 3.14.0 - Cross-site Scripting (XSS) (nuclei): http/cves/2023/CVE-2023-1496.yaml

## Other vulnerabilities in imgproxy/imgproxy

- [CVE-2023-30019](https://insights.sbomify.com/CVE-2023-30019/): imgproxy is vulnerable to Server-Side Request Forgery (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-1496 and fix it if it is affected.

What it is: CVE-2023-1496 is a medium-severity cross-site scripting vulnerability in imgproxy/imgproxy, published on 19 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-1496 exists.

Affected packages and fixed versions:
- github.com/imgproxy/imgproxy/v3 (Go): affected all versions; fixed in 3.14.0
- github.com/imgproxy/imgproxy/v3 (Go): affected all versions; fixed in 3.14.0
- github.com/imgproxy/imgproxy/v3 (Go): affected all versions; fixed in 3.14.0
- github.com/imgproxy/imgproxy (Go): affected all versions; no fix listed
- github.com/imgproxy/imgproxy/v2 (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-1496/ (Markdown: https://insights.sbomify.com/CVE-2023-1496/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-1496
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-1496
- OSV: https://osv.dev/vulnerability/CVE-2023-1496

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-1496/
Summaries are generated and may contain mistakes; the official description above is the record.
