{"answers":{"affected":"2 open source packages ship an affected version, including sccache. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-1521 in the wild and no public exploit code.","fix":"Upgrade sccache to 0.4.0 or later.","what":"CVE-2023-1521 is a high-severity vulnerability in Mozilla sccache, published on 26 Nov 2024. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-1521 and fix it if it is affected.\n\nWhat it is: CVE-2023-1521 is a high-severity vulnerability in Mozilla sccache, published on 26 Nov 2024. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-1521 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- sccache (crates.io): affected all versions; fixed in 0.4.0\n- sccache (crates.io): affected all versions; fixed in 0.4.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-1521/ (Markdown: https://insights.sbomify.com/CVE-2023-1521/index.md)","id":"CVE-2023-1521","markdown":"https://insights.sbomify.com/CVE-2023-1521/index.md","name":"CVE-2023-1521","record":{"aliases":["DEBIAN-CVE-2023-1521","GHSA-x7fr-pg8f-93f5","UBUNTU-CVE-2023-1521"],"analysis":{"component_type":"developer_tool","fix_type":"patch","impacts":["privilege_escalation","code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"sccache compiler cache","requires_auth":"low_privilege","summary":"A local attacker can escalate privileges to root by exploiting LD_PRELOAD in sccache, particularly when the server runs as root via snap.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mozilla","cpe":[{"product":"sccache","vendor":"mozilla"}],"cvss":{"score":7.8,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-426","name":"Untrusted Search Path"}],"description":"On Linux the sccache client can execute arbitrary code with the privileges of a local sccache server, by preloading the code in a shared library passed to LD_PRELOAD.\n\nIf the server is run as root (which is the default when installing the  snap package https://snapcraft.io/sccache ), this means a user running the sccache client can get root privileges.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":"2023-11-15","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2023-11-15T15:31:44Z","kind":"github_poc","ref":"https://github.com/rubbxalc/CVE-2023-1521","stars":0,"title":null}],"tier":"poc_unverified"},"has_fix":true,"headline":"Local Privilege Escalation in sccache","id":"CVE-2023-1521","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"privilege_escalation","year":"2023"},"n_packages":2,"n_references":2,"next":{"headline":"SQL injection in Genetec Security Center","id":"CVE-2023-1522"},"packages":[{"ecosystem":"crates.io","fixed":["0.4.0"],"introduced":["0"],"last_affected":[],"package":"sccache","purl":null,"source":"GHSA-x7fr-pg8f-93f5"},{"ecosystem":"crates.io","fixed":["0.4.0"],"introduced":["0"],"last_affected":[],"package":"sccache","purl":"pkg:cargo/sccache","source":"GHSA-x7fr-pg8f-93f5"}],"prev":{"headline":"Information disclosure in KVMS Pro","id":"CVE-2023-1518"},"products":["sccache"],"published":"2024-11-26","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-11-26","vendors":["Mozilla"]},"summary":"A local attacker can escalate privileges to root by exploiting LD_PRELOAD in sccache, particularly when the server runs as root via snap.","url":"https://insights.sbomify.com/CVE-2023-1521/"}