# CVE-2023-1539: Improper Restriction of Excessive Authentication Attempts in answerdev/answer

> Attackers can bypass authentication attempt limits in Answer, potentially enabling brute-force attacks to take over user accounts.

- **Severity:** Medium 5.3 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Mar 2023
- **Updated:** 27 Feb 2025
- **Also known as:** GHSA-g44v-6qfm-f6ch, GO-2023-1657

## What is CVE-2023-1539?

CVE-2023-1539 is a medium-severity vulnerability in answerdev/answer, published on 21 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Improper Restriction of Excessive Authentication Attempts in GitHub repository answerdev/answer prior to 1.0.6.

Weakness: CWE-307 (Improper Restriction of Excessive Authentication Attempts)

## Which versions are affected by CVE-2023-1539?

3 open source packages ship an affected version, including github.com/answerdev/answer. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/answerdev/answer` | Go | All versions | 1.0.6 |
| `github.com/answerdev/answer` | Go | All versions | 1.0.6 |
| `github.com/answerdev/answer` | Go | All versions | 1.0.6 |

Products: Answer Answer.

## How do I fix CVE-2023-1539?

Upgrade github.com/answerdev/answer to 1.0.6 or later.

## Is CVE-2023-1539 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-1539 exists.

## Other vulnerabilities in answerdev/answer

- [CVE-2023-0744](https://insights.sbomify.com/CVE-2023-0744/): Improper Access Control in answerdev/answer (critical 9.8)
- [CVE-2023-1244](https://insights.sbomify.com/CVE-2023-1244/): Cross-site Scripting (XSS) - Stored in answerdev/answer (critical 9.3)
- [CVE-2023-4125](https://insights.sbomify.com/CVE-2023-4125/): Weak Password Requirements in answerdev/answer (high 8.8)
- [CVE-2023-1241](https://insights.sbomify.com/CVE-2023-1241/): Cross-site Scripting (XSS) - Stored in answerdev/answer (high 8.8)
- [CVE-2023-4815](https://insights.sbomify.com/CVE-2023-4815/): Missing Authentication for Critical Function in answerdev/answer (high 8.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-1539 and fix it if it is affected.

What it is: CVE-2023-1539 is a medium-severity vulnerability in answerdev/answer, published on 21 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-1539 exists.

Affected packages and fixed versions:
- github.com/answerdev/answer (Go): affected all versions; fixed in 1.0.6
- github.com/answerdev/answer (Go): affected all versions; fixed in 1.0.6
- github.com/answerdev/answer (Go): affected all versions; fixed in 1.0.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-1539/ (Markdown: https://insights.sbomify.com/CVE-2023-1539/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-1539
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-1539
- OSV: https://osv.dev/vulnerability/CVE-2023-1539

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-1539/
Summaries are generated and may contain mistakes; the official description above is the record.
