{"answers":{"affected":"3 open source packages ship an affected version, including github.com/answerdev/answer. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-1543 exists.","fix":"Upgrade github.com/answerdev/answer to 1.0.6 or later.","what":"CVE-2023-1543 is a medium-severity vulnerability in answerdev/answer, published on 21 Mar 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-1543 and fix it if it is affected.\n\nWhat it is: CVE-2023-1543 is a medium-severity vulnerability in answerdev/answer, published on 21 Mar 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-1543 exists.\n\nAffected packages and fixed versions:\n- github.com/answerdev/answer (Go): affected all versions; fixed in 1.0.6\n- github.com/answerdev/answer (Go): affected all versions; fixed in 1.0.6\n- github.com/answerdev/answer (Go): affected all versions; fixed in 1.0.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-1543/ (Markdown: https://insights.sbomify.com/CVE-2023-1543/index.md)","id":"CVE-2023-1543","markdown":"https://insights.sbomify.com/CVE-2023-1543/index.md","name":"CVE-2023-1543","record":{"aliases":["GHSA-79hx-g43v-xfmr","GO-2023-1655"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Answer Q\u0026A platform","requires_auth":"high_privilege","summary":"Attackers can maintain unauthorized access due to insufficient session expiration in the Answer Q\u0026A platform.","user_interaction":"required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"@huntrdev","cpe":[{"product":"answer","vendor":"answer"}],"cvss":{"score":6.8,"severity":"medium","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-613","name":"DEPRECATED: Insufficient Session Expiration"}],"description":"Insufficient Session Expiration in GitHub repository answerdev/answer prior to 1.0.6.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Insufficient Session Expiration in answerdev/answer","id":"CVE-2023-1543","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"security_feature_bypass","year":"2023"},"n_packages":3,"n_references":2,"next":{"headline":"Qemu: pvrdma: out-of-bounds read in pvrdma_ring_next_elem_read()","id":"CVE-2023-1544"},"packages":[{"ecosystem":"Go","fixed":["1.0.6"],"introduced":["0"],"last_affected":[],"package":"github.com/answerdev/answer","purl":null,"source":"GHSA-79hx-g43v-xfmr"},{"ecosystem":"Go","fixed":["1.0.6"],"introduced":["0"],"last_affected":[],"package":"github.com/answerdev/answer","purl":"pkg:golang/github.com/answerdev/answer","source":"GHSA-79hx-g43v-xfmr"},{"ecosystem":"Go","fixed":["1.0.6"],"introduced":["0"],"last_affected":[],"package":"github.com/answerdev/answer","purl":"pkg:golang/github.com/answerdev/answer","source":"GO-2023-1655"}],"prev":{"headline":"Business Logic Errors in answerdev/answer","id":"CVE-2023-1542"},"products":["answerdev/answer"],"published":"2023-03-21","related":[{"cvss_score":9.8,"headline":"Improper Access Control in answerdev/answer","id":"CVE-2023-0744","kev_date_added":null,"published":"2023-02-08"},{"cvss_score":9.3,"headline":"Cross-site Scripting (XSS) - Stored in answerdev/answer","id":"CVE-2023-1244","kev_date_added":null,"published":"2023-03-07"},{"cvss_score":8.8,"headline":"Weak Password Requirements in answerdev/answer","id":"CVE-2023-4125","kev_date_added":null,"published":"2023-08-03"},{"cvss_score":8.8,"headline":"Cross-site Scripting (XSS) - Stored in answerdev/answer","id":"CVE-2023-1241","kev_date_added":null,"published":"2023-03-07"},{"cvss_score":8.3,"headline":"Missing Authentication for Critical Function in answerdev/answer","id":"CVE-2023-4815","kev_date_added":null,"published":"2023-09-07"},{"cvss_score":8.3,"headline":"Cross-site Scripting (XSS) - Stored in answerdev/answer","id":"CVE-2023-1535","kev_date_added":null,"published":"2023-03-21"},{"cvss_score":8.2,"headline":"Cross-site Scripting (XSS) - Stored in answerdev/answer","id":"CVE-2023-0740","kev_date_added":null,"published":"2023-02-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-02-26","vendors":["answerdev"]},"summary":"Attackers can maintain unauthorized access due to insufficient session expiration in the Answer Q\u0026A platform.","url":"https://insights.sbomify.com/CVE-2023-1543/"}