# CVE-2023-1550: NGINX Agent vulnerability CVE-2023-1550

> An authenticated local attacker can read private keys from log files if trace logging is enabled in NGINX Agent.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Mar 2023
- **Updated:** 13 Feb 2025
- **Also known as:** BIT-nginx-agent-2023-1550, GHSA-68qv-j282-p3jm

## What is CVE-2023-1550?

CVE-2023-1550 is a medium-severity vulnerability in F5 NGINX Agent, published on 29 Mar 2023. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Insertion of Sensitive Information into log file vulnerability in NGINX Agent. NGINX Agent version 2.0 before 2.23.3 inserts sensitive information into a log file. An authenticated attacker with local access to read agent log files may gain access to private keys. This issue is only exposed when the non-default trace level logging is enabled. Note: NGINX Agent is included with NGINX Instance Manager and used in conjunction with NGINX API Connectivity Manager, and NGINX Management Suite Security Monitoring.

Weakness: CWE-532 (Insertion of Sensitive Information into Log File)

## Which versions are affected by CVE-2023-1550?

1 open source package ship an affected version, including nginx-agent. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nginx-agent` | Bitnami | From 2.0.0 | 2.23.3 |

Products: F5 Nginx Agent, F5 Nginx Instance Manager.

## How do I fix CVE-2023-1550?

Upgrade nginx-agent to 2.23.3 or later.

## Is CVE-2023-1550 being exploited?

There is no known exploitation of CVE-2023-1550 in the wild and no public exploit code.

## Other vulnerabilities in F5 NGINX Agent

- [CVE-2024-7634](https://insights.sbomify.com/CVE-2024-7634/): NGINX Agent Vulnerability (medium 6.9)
- [CVE-2026-60062](https://insights.sbomify.com/CVE-2026-60062/): NGINX Agent Vulnerability (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-1550 and fix it if it is affected.

What it is: CVE-2023-1550 is a medium-severity vulnerability in F5 NGINX Agent, published on 29 Mar 2023. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-1550 in the wild and no public exploit code.

Affected packages and fixed versions:
- nginx-agent (Bitnami): affected from 2.0.0; fixed in 2.23.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-1550/ (Markdown: https://insights.sbomify.com/CVE-2023-1550/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-1550
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-1550
- OSV: https://osv.dev/vulnerability/CVE-2023-1550

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-1550/
Summaries are generated and may contain mistakes; the official description above is the record.
