{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-1552 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2023-1552 yet. Limit exposure of the affected software until one is available.","what":"CVE-2023-1552 is a low-severity unsafe deserialization vulnerability in GE Gas Power ToolboxST, published on 11 Apr 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-1552 and fix it if it is affected.\n\nWhat it is: CVE-2023-1552 is a low-severity unsafe deserialization vulnerability in GE Gas Power ToolboxST, published on 11 Apr 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2023-1552 in the wild and no public exploit code.\n\nAffected product: GE Gas Power ToolboxST. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-1552/ (Markdown: https://insights.sbomify.com/CVE-2023-1552/index.md)","id":"CVE-2023-1552","markdown":"https://insights.sbomify.com/CVE-2023-1552/index.md","name":"CVE-2023-1552","record":{"aliases":["GHSA-xv45-qm36-h77q"],"analysis":{"component_type":"ics_ot","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"GE ToolboxST","requires_auth":"high_privilege","summary":"An attacker with local access or via social engineering can execute arbitrary code in a ToolboxST user's context by exploiting a deserialization vulnerability in configuration files.","user_interaction":"required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GE GP","cpe":[{"product":"toolboxst","vendor":"ge"}],"cvss":{"score":2.9,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:L/AC:H/PR:H/UI:R/S:U/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"ToolboxST prior to version 7.10 is affected by a deserialization vulnerability. An attacker with local access to an HMI or who has conducted a social engineering attack on an authorized operator could execute code in a Toolbox user's context through the deserialization of an untrusted configuration file. Two CVSS scores have been provided to capture the differences between the two aforementioned attack vectors. \n\nCustomers are advised to update to ToolboxST 7.10 which can be found in ControlST 7.10. If unable to update at this time customers should ensure they are following the guidance laid out in GE Gas Power's Secure Deployment Guide (GEH-6839). Customers should ensure they are not running ToolboxST as an Administrative user.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"ToolboxST Deserialization of Untrusted Configuration Data","id":"CVE-2023-1552","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"deserialization","year":"2023"},"n_packages":0,"n_references":1,"next":{"headline":"Quick Paypal Payments \u003c 5.7.26.4 - Admin+ Stored XSS","id":"CVE-2023-1554"},"packages":[],"prev":{"headline":"NGINX Agent vulnerability CVE-2023-1550","id":"CVE-2023-1550"},"products":["ToolboxST"],"published":"2023-04-11","related":[{"cvss_score":7.5,"headline":"GE Gas Power ToolBoxST Improper Restriction of XML External Entity Reference","id":"CVE-2021-44477","kev_date_added":null,"published":"2022-03-25"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-02-06","vendors":["GE Gas Power"]},"summary":"An attacker with local access or via social engineering can execute arbitrary code in a ToolboxST user's context by exploiting a deserialization vulnerability in configuration files.","url":"https://insights.sbomify.com/CVE-2023-1552/"}