CVE-2023-1555 Missing Authorization in GitLab
A banned user can bypass restrictions to access the GitLab API, allowing unauthorized data retrieval.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-1555?
CVE-2023-1555 is a low-severity missing authorization vulnerability in Gitlab Gitlab, published on 1 Sep 2023. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
An issue has been discovered in GitLab affecting all versions starting from 15.2 before 16.1.5, all versions starting from 16.2 before 16.2.5, all versions starting from 16.3 before 16.3.1. A namespace-level banned user can access the API.
Weakness: CWE-262
Which versions are affected by CVE-2023-1555?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 15.2.0 | 16.1.5, 16.2.5, 16.3.1 |
Products include Gitlab Gitlab.
How do I fix CVE-2023-1555?
Upgrade gitlab to a fixed version for your release line: 16.1.5, 16.2.5 or 16.3.1.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2023-1555 being exploited?
There is no known exploitation of CVE-2023-1555 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2023-1555, GHSA-wc5c-7jg2-cprf, UBUNTU-CVE-2023-1555.