{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-1572 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2023-1572 yet. Limit exposure of the affected software until one is available.","what":"CVE-2023-1572 is a low-severity cross-site scripting vulnerability in DataGear, published on 22 Mar 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-1572 and fix it if it is affected.\n\nWhat it is: CVE-2023-1572 is a low-severity cross-site scripting vulnerability in DataGear, published on 22 Mar 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2023-1572 in the wild and no public exploit code.\n\nAffected product: DataGear. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-1572/ (Markdown: https://insights.sbomify.com/CVE-2023-1572/index.md)","id":"CVE-2023-1572","markdown":"https://insights.sbomify.com/CVE-2023-1572/index.md","name":"CVE-2023-1572","record":{"aliases":["GHSA-f792-rc34-g659"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["other"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"DataGear","requires_auth":"high_privilege","summary":"Attackers can inject malicious scripts into DataGear via the Plugin Handler, potentially compromising user sessions or data.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"datagear","vendor":"datagear"}],"cvss":{"score":2,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:H/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A vulnerability has been found in DataGear up to 1.11.1 and classified as problematic. This vulnerability affects unknown code of the component Plugin Handler. The manipulation leads to cross site scripting. It is possible to launch the attack on the local host. The exploit has been disclosed to the public and may be used. Upgrading to version 1.12.0 is able to address this issue. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-223564.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"DataGear Plugin cross site scripting","id":"CVE-2023-1572","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2023"},"n_packages":0,"n_references":5,"next":{"headline":"DataGear Graph Dataset cross site scripting","id":"CVE-2023-1573"},"packages":[],"prev":{"headline":"DataGear pagingQueryData sql injection","id":"CVE-2023-1571"},"products":["DataGear"],"published":"2023-03-22","related":[{"cvss_score":9.8,"headline":"Code injection in n/a","id":"CVE-2024-37759","kev_date_added":null,"published":"2024-06-24"},{"cvss_score":9.1,"headline":"Path traversal in n/a","id":"CVE-2025-65792","kev_date_added":null,"published":"2025-12-10"},{"cvss_score":6.3,"headline":"DataGear pagingQueryData sql injection","id":"CVE-2023-1571","kev_date_added":null,"published":"2023-03-22"},{"cvss_score":5.3,"headline":"DataGear resolveSql sql injection","id":"CVE-2023-7299","kev_date_added":null,"published":"2024-11-23"},{"cvss_score":5.3,"headline":"DataGear Data Schema Page ConversionSqlParamValueMapper.java evaluateVariableExpression expression language injection","id":"CVE-2024-7552","kev_date_added":null,"published":"2024-08-06"},{"cvss_score":5.3,"headline":"DataGear JDBC Server deserialization","id":"CVE-2023-2042","kev_date_added":null,"published":"2023-04-14"},{"cvss_score":3.5,"headline":"DataGear Diagram Type cross site scripting","id":"CVE-2023-1772","kev_date_added":null,"published":"2023-03-31"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-02-25","vendors":["n/a"]},"summary":"Attackers can inject malicious scripts into DataGear via the Plugin Handler, potentially compromising user sessions or data.","url":"https://insights.sbomify.com/CVE-2023-1572/"}