{"answers":{"affected":"It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-1605 exists.","fix":"Upgrade to a fixed version.","what":"CVE-2023-1605 is a high-severity denial of service vulnerability in Radare Radare2, published on 23 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-1605 and fix it if it is affected.\n\nWhat it is: CVE-2023-1605 is a high-severity denial of service vulnerability in Radare Radare2, published on 23 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-1605 exists.\n\nAffected product: Radare Radare2. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-1605/ (Markdown: https://insights.sbomify.com/CVE-2023-1605/index.md)","id":"CVE-2023-1605","markdown":"https://insights.sbomify.com/CVE-2023-1605/index.md","name":"CVE-2023-1605","record":{"aliases":["GHSA-88pw-p67x-2jrr","UBUNTU-CVE-2023-1605","openSUSE-SU-2024:12941-1"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"radare2 reverse engineering tool","requires_auth":"none","summary":"An attacker can cause a denial of service in radare2 by exploiting a flaw in the application, requiring users to upgrade to a patched version.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"@huntrdev","cpe":[{"product":"radare2","vendor":"radare"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.0"},"cwes":[{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"Denial of Service in GitHub repository radareorg/radare2 prior to 5.8.6.","ecosystems":["openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Denial of Service in radareorg/radare2","id":"CVE-2023-1605","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"radare:radare2","products":["radare:radare2"],"type":"denial_of_service","year":"2023"},"n_packages":1,"n_references":2,"next":{"headline":"novel-plus DictController.java sql injection","id":"CVE-2023-1606"},"packages":[{"ecosystem":"openSUSE:Tumbleweed","fixed":["5.8.6-1.1"],"introduced":["0"],"last_affected":[],"package":"radare2","purl":"pkg:rpm/opensuse/radare2\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:12941-1"}],"prev":{"headline":"Short URL \u003c= 1.6.8 - Cross-Site Request Forgery via configuration_page","id":"CVE-2023-1604"},"products":["radareorg/radare2"],"published":"2023-03-23","related":[{"cvss_score":10,"headline":"Buffer Overflow and Potential Code Execution in Radare2","id":"CVE-2025-1864","kev_date_added":null,"published":"2025-03-03"},{"cvss_score":10,"headline":"Out-of-bounds Write in radare2","id":"CVE-2025-1744","kev_date_added":null,"published":"2025-02-28"},{"cvss_score":10,"headline":"Denial of service in radare2","id":"CVE-2021-32494","kev_date_added":null,"published":"2023-07-07"},{"cvss_score":10,"headline":"Use after free in radare2","id":"CVE-2021-32495","kev_date_added":null,"published":"2023-07-07"},{"cvss_score":9.8,"headline":"Memory corruption in n/a","id":"CVE-2024-29646","kev_date_added":null,"published":"2024-12-17"},{"cvss_score":9.8,"headline":"Memory corruption in n/a","id":"CVE-2023-46569","kev_date_added":null,"published":"2023-10-28"},{"cvss_score":9.8,"headline":"Memory corruption in n/a","id":"CVE-2023-46570","kev_date_added":null,"published":"2023-10-28"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-02-25","vendors":["radareorg"]},"summary":"An attacker can cause a denial of service in radare2 by exploiting a flaw in the application, requiring users to upgrade to a patched version.","url":"https://insights.sbomify.com/CVE-2023-1605/"}