# CVE-2023-1624: WPCode Lite < 2.0.9 - Arbitrary Log File Deletion via CSRF

> Attackers can trick users into deleting arbitrary log files on the server via CSRF, potentially causing data loss or service disruption.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 24 Apr 2023
- **Updated:** 4 Feb 2025
- **Also known as:** GHSA-2h2j-55g7-g43c

## What is CVE-2023-1624?

CVE-2023-1624 is a medium-severity vulnerability in Unknown WPCode, published on 24 Apr 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

The WPCode WordPress plugin before 2.0.9 has a flawed CSRF when deleting log, and does not ensure that the file to be deleted is inside the expected folder. This could allow attackers to make users with the wpcode_activate_snippets capability delete arbitrary log files on the server, including outside of the blog folders

## Which versions are affected by CVE-2023-1624?

It affects 1 product.


Products: Wpcode Wpcode.

## How do I fix CVE-2023-1624?

No fix has been published for CVE-2023-1624 yet. Limit exposure of the affected software until one is available.

## Is CVE-2023-1624 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-1624 exists.

## Other vulnerabilities in Unknown WPCode

- [CVE-2023-3524](https://insights.sbomify.com/CVE-2023-3524/): WPCode < 2.0.13.1 - Reflected XSS (medium 6.1)
- [CVE-2023-0328](https://insights.sbomify.com/CVE-2023-0328/): WPCode < 2.0.7 - Contributor+ WPCode Library Auth Key Update/Deletion (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-1624 and fix it if it is affected.

What it is: CVE-2023-1624 is a medium-severity vulnerability in Unknown WPCode, published on 24 Apr 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-1624 exists.

Affected product: Unknown WPCode. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-1624/ (Markdown: https://insights.sbomify.com/CVE-2023-1624/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-1624
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-1624
- OSV: https://osv.dev/vulnerability/CVE-2023-1624

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-1624/
Summaries are generated and may contain mistakes; the official description above is the record.
