# CVE-2023-1664: Keycloak Untrusted Certificate Validation vulnerability

> Attackers can bypass client certificate validation in Keycloak if specific non-default configurations are misconfigured, potentially compromising integrity or confidentiality.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 May 2023
- **Updated:** 15 Jan 2025
- **Also known as:** GHSA-5cc8-pgp5-7mpm

## What is CVE-2023-1664?

CVE-2023-1664 is a medium-severity vulnerability in Redhat Keycloak, published on 26 May 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A flaw was found in Keycloak. This flaw depends on a non-default configuration "Revalidate Client Certificate" to be enabled and the reverse proxy is not validating the certificate before Keycloak. Using this method an attacker may choose the certificate which will be validated by the server. If this happens and the KC_SPI_TRUSTSTORE_FILE_FILE variable is missing/misconfigured, any trustfile may be accepted with the logging information of "Cannot validate client certificate trust: Truststore not available". This may not impact availability as the attacker would have no access to the server, but consumer applications Integrity or Confidentiality may be impacted considering a possible access to them. Considering the environment is correctly set to use "Revalidate Client Certificate" this flaw is avoidable.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2023-1664?

2 open source packages ship an affected version, including org.keycloak:keycloak-core. It affects 5 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.keycloak:keycloak-core` | Maven | All versions | 21.1.2 |
| `org.keycloak:keycloak-core` | Maven | All versions | 21.1.2 |

Products: Redhat Build of Quarkus, Redhat Jboss A-Mq, Redhat Keycloak, Redhat Migration Toolkit for Runtimes, Redhat Single Sign-On.

## How do I fix CVE-2023-1664?

Upgrade org.keycloak:keycloak-core to 21.1.2 or later.

## Is CVE-2023-1664 being exploited?

There is no known exploitation of CVE-2023-1664 in the wild and no public exploit code.

## Other vulnerabilities in Redhat Keycloak

- [CVE-2022-4492](https://insights.sbomify.com/CVE-2022-4492/): Undertow client not checking server identity presented by server certificate in https connections (high 7.5)
- [CVE-2023-2974](https://insights.sbomify.com/CVE-2023-2974/): quarkus-core vulnerable to client driven TLS cipher downgrading (medium 6.5)
- [CVE-2021-3914](https://insights.sbomify.com/CVE-2021-3914/): SmallRye Health UI Cross-site Scripting vulnerability (medium 6.1)
- [CVE-2023-6393](https://insights.sbomify.com/CVE-2023-6393/): Quarkus: potential invalid reuse of context when @cacheresult on a uni is used (medium 5.3)
- [CVE-2021-3536](https://insights.sbomify.com/CVE-2021-3536/): Cross-site Scripting in Wildfly (medium 4.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-1664 and fix it if it is affected.

What it is: CVE-2023-1664 is a medium-severity vulnerability in Redhat Keycloak, published on 26 May 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-1664 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.keycloak:keycloak-core (Maven): affected all versions; fixed in 21.1.2
- org.keycloak:keycloak-core (Maven): affected all versions; fixed in 21.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-1664/ (Markdown: https://insights.sbomify.com/CVE-2023-1664/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-1664
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-1664
- OSV: https://osv.dev/vulnerability/CVE-2023-1664

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-1664/
Summaries are generated and may contain mistakes; the official description above is the record.
