# CVE-2023-1699: Rapid7 Nexpose Forced Browsing

> Attackers can access administrative pages without authorization by manipulating URLs, exposing sensitive management functions in Rapid7 Nexpose.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 30 Mar 2023
- **Updated:** 11 Feb 2025
- **Also known as:** GHSA-hhqx-5j72-qf6h

## What is CVE-2023-1699?

CVE-2023-1699 is a medium-severity missing authorization vulnerability in Rapid7 Nexpose, published on 30 Mar 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Rapid7 Nexpose versions 6.6.186 and below suffer from a forced browsing vulnerability.  This vulnerability allows an attacker to manipulate URLs to forcefully browse to and access administrative pages. This vulnerability is fixed in version 6.6.187.

Weakness: CWE-425 (Direct Request)

## Which versions are affected by CVE-2023-1699?

It affects 1 product.


Products: Rapid7 Nexpose.

## How do I fix CVE-2023-1699?

No fix has been published for CVE-2023-1699 yet. Limit exposure of the affected software until one is available.

## Is CVE-2023-1699 being exploited?

There is no known exploitation of CVE-2023-1699 in the wild and no public exploit code.

## Other vulnerabilities in Rapid7 Nexpose

- [CVE-2017-5264](https://insights.sbomify.com/CVE-2017-5264/): Cross-site request forgery in Nexpose (high 8.8)
- [CVE-2019-5638](https://insights.sbomify.com/CVE-2019-5638/): Rapid7 Nexpose Insufficient Session Management (high 8.7)
- [CVE-2017-5243](https://insights.sbomify.com/CVE-2017-5243/): Weak cryptography in Nexpose hardware appliance (high 8.5)
- [CVE-2017-5232](https://insights.sbomify.com/CVE-2017-5232/): Other in Nexpose (high 7.8)
- [CVE-2017-5230](https://insights.sbomify.com/CVE-2017-5230/): Hardcoded credentials in Nexpose (high 7.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-1699 and fix it if it is affected.

What it is: CVE-2023-1699 is a medium-severity missing authorization vulnerability in Rapid7 Nexpose, published on 30 Mar 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-1699 in the wild and no public exploit code.

Affected product: Rapid7 Nexpose. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-1699/ (Markdown: https://insights.sbomify.com/CVE-2023-1699/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-1699
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-1699
- OSV: https://osv.dev/vulnerability/CVE-2023-1699

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-1699/
Summaries are generated and may contain mistakes; the official description above is the record.
