CVE-2023-1708 Command injection in GitLab

Medium 5.7 Published Updated

Attackers can execute unexpected commands on victim machines by exploiting how GitLab handles non-printable characters copied from the clipboard.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2023-1708?

CVE-2023-1708 is a medium-severity command injection vulnerability in Gitlab Gitlab, published on 5 Apr 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

An issue was identified in GitLab CE/EE affecting all versions from 1.0 prior to 15.8.5, 15.9 prior to 15.9.4, and 15.10 prior to 15.10.1 where non-printable characters gets copied from clipboard, allowing unexpected commands to be executed on victim machine.

Weakness: CWE-77, CWE-94

Which versions are affected by CVE-2023-1708?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 1.0.015.8.5, 15.9.4, 15.10.1

Products include Gitlab Gitlab.

How do I fix CVE-2023-1708?

Upgrade gitlab to a fixed version for your release line: 15.8.5, 15.9.4 or 15.10.1.

Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.

Is CVE-2023-1708 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-1708 exists.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2023-1708, GHSA-phjw-j3fx-vxpj, UBUNTU-CVE-2023-1708.

Is CVE-2023-1708 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free