{"answers":{"affected":"2 open source packages ship an affected version, including thorsten/phpmyfaq. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-1762 exists.","fix":"Upgrade thorsten/phpmyfaq to 3.1.12 or later.","what":"CVE-2023-1762 is a high-severity vulnerability in Phpmyfaq Phpmyfaq, published on 31 Mar 2023. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-1762 and fix it if it is affected.\n\nWhat it is: CVE-2023-1762 is a high-severity vulnerability in Phpmyfaq Phpmyfaq, published on 31 Mar 2023. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-1762 exists.\n\nAffected packages and fixed versions:\n- thorsten/phpmyfaq (Packagist): affected all versions; fixed in 3.1.12\n- thorsten/phpmyfaq (Packagist): affected all versions; fixed in 3.1.12\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-1762/ (Markdown: https://insights.sbomify.com/CVE-2023-1762/index.md)","id":"CVE-2023-1762","markdown":"https://insights.sbomify.com/CVE-2023-1762/index.md","name":"CVE-2023-1762","record":{"aliases":["GHSA-xww4-w6ff-5q3g"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"phpMyFAQ","requires_auth":"high_privilege","summary":"Attackers can exploit improper privilege management in phpMyFAQ to escalate privileges within the application.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"@huntrdev","cpe":[{"product":"phpmyfaq","vendor":"phpmyfaq"}],"cvss":{"score":7.2,"severity":"high","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-269","name":"Improper Privilege Management"}],"description":"Improper Privilege Management in GitHub repository thorsten/phpmyfaq prior to 3.1.12.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Improper Privilege Management in thorsten/phpmyfaq","id":"CVE-2023-1762","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"phpmyfaq:phpmyfaq","products":["phpmyfaq:phpmyfaq"],"type":"privilege_escalation","year":"2023"},"n_packages":2,"n_references":2,"next":{"headline":"Information disclosure in Canon IJ NW Tool","id":"CVE-2023-1763"},"packages":[{"ecosystem":"Packagist","fixed":["3.1.12"],"introduced":["0"],"last_affected":[],"package":"thorsten/phpmyfaq","purl":null,"source":"GHSA-xww4-w6ff-5q3g"},{"ecosystem":"Packagist","fixed":["3.1.12"],"introduced":["0"],"last_affected":[],"package":"thorsten/phpmyfaq","purl":"pkg:composer/thorsten/phpmyfaq","source":"GHSA-xww4-w6ff-5q3g"}],"prev":{"headline":"Cross-site Scripting in thorsten/phpmyfaq","id":"CVE-2023-1761"},"products":["thorsten/phpmyfaq"],"published":"2023-03-31","related":[{"cvss_score":9.8,"headline":"Cross-site Scripting (XSS) - Stored in thorsten/phpmyfaq","id":"CVE-2023-0310","kev_date_added":null,"published":"2023-01-15"},{"cvss_score":9.8,"headline":"Cross-site Scripting (XSS) - Reflected in thorsten/phpmyfaq","id":"CVE-2022-4407","kev_date_added":null,"published":"2022-12-11"},{"cvss_score":9.8,"headline":"Security feature bypass in n/a","id":"CVE-2017-11187","kev_date_added":null,"published":"2017-07-12"},{"cvss_score":9.1,"headline":"phpMyFAQ before 4.1.7 2FA Brute-Force via Session-Scoped Throttle","id":"CVE-2026-76213","kev_date_added":null,"published":"2026-08-19"},{"cvss_score":9.1,"headline":"phpMyFAQ before 4.1.7 WebAuthn Replay Attack via Challenge","id":"CVE-2026-76214","kev_date_added":null,"published":"2026-08-19"},{"cvss_score":9.1,"headline":"Cross-site Scripting (XSS) - DOM in thorsten/phpmyfaq","id":"CVE-2023-5316","kev_date_added":null,"published":"2023-09-30"},{"cvss_score":9.1,"headline":"Cross-site Scripting (XSS) - Stored in thorsten/phpmyfaq","id":"CVE-2023-0306","kev_date_added":null,"published":"2023-01-15"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-02-12","vendors":["thorsten"]},"summary":"Attackers can exploit improper privilege management in phpMyFAQ to escalate privileges within the application.","url":"https://insights.sbomify.com/CVE-2023-1762/"}