# CVE-2023-1774: Unauthorized email invite to a private channel

> Attackers can invite themselves to private channels due to missing permission checks, gaining unauthorized access to restricted communications.

- **Severity:** Medium 4.2 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Mar 2023
- **Updated:** 6 Dec 2024
- **Also known as:** BIT-mattermost-2023-1774, GHSA-9hj7-v56g-rhf6

## What is CVE-2023-1774?

CVE-2023-1774 is a medium-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 31 Mar 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

When processing an email invite to a private channel on a team, Mattermost fails to validate the inviter's permission to that channel, allowing an attacker to invite themselves to a private channel.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2023-1774?

11 open source packages ship an affected version, including github.com/mattermost/mattermost-server, mattermost and github.com/mattermost/mattermost-server/v5. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/mattermost/mattermost-server` | Go | From 3.3.0 | 7.1.6 |
| `github.com/mattermost/mattermost-server` | Go | From 3.3.0 | 7.1.6 |
| `github.com/mattermost/mattermost-server` | Go | From 7.1.0 | 7.1.6 |
| `github.com/mattermost/mattermost-server` | Go | From 7.1.0 | 7.1.6 |
| `github.com/mattermost/mattermost-server` | Go | From 7.7.0 | 7.7.2 |
| `github.com/mattermost/mattermost-server` | Go | From 7.7.0 | 7.7.2 |
| `mattermost` | Bitnami | All versions to 7.7.1 | 7.1.6 |
| `github.com/mattermost/mattermost-server/v5` | Go | From 5.0.0 | 7.1.6 |
| `github.com/mattermost/mattermost-server/v5` | Go | From 5.0.0 | 7.1.6 |
| `github.com/mattermost/mattermost-server/v6` | Go | From 6.0.0 | 7.1.6 |
| `github.com/mattermost/mattermost-server/v6` | Go | From 6.0.0 | 7.1.6 |

Products: Mattermost Mattermost Server.

## How do I fix CVE-2023-1774?

Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 7.1.6 or 7.7.2.

## Is CVE-2023-1774 being exploited?

There is no known exploitation of CVE-2023-1774 in the wild and no public exploit code.

## Other vulnerabilities in Mattermost Mattermost Server

- [CVE-2025-12419](https://insights.sbomify.com/CVE-2025-12419/): Account takeover on OAuth/OpenID-enabled servers (critical 9.9)
- [CVE-2025-12421](https://insights.sbomify.com/CVE-2025-12421/): Account Takeover via Code Exchange Endpoint (critical 9.9)
- [CVE-2025-4981](https://insights.sbomify.com/CVE-2025-4981/): Path Traversal Leading to RCE by Any Authenticated Mattermost User (critical 9.9)
- [CVE-2025-20051](https://insights.sbomify.com/CVE-2025-20051/): Arbitrary file read via block duplication in Mattermost Boards (critical 9.9)
- [CVE-2025-25279](https://insights.sbomify.com/CVE-2025-25279/): Arbitrary file read in Mattermost Boards via import & export board archive (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-1774 and fix it if it is affected.

What it is: CVE-2023-1774 is a medium-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 31 Mar 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-1774 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/mattermost/mattermost-server (Go): affected from 3.3.0; fixed in 7.1.6
- github.com/mattermost/mattermost-server (Go): affected from 3.3.0; fixed in 7.1.6
- github.com/mattermost/mattermost-server (Go): affected from 7.1.0; fixed in 7.1.6
- github.com/mattermost/mattermost-server (Go): affected from 7.1.0; fixed in 7.1.6
- github.com/mattermost/mattermost-server (Go): affected from 7.7.0; fixed in 7.7.2
- github.com/mattermost/mattermost-server (Go): affected from 7.7.0; fixed in 7.7.2
- mattermost (Bitnami): affected all versions up to 7.7.1; fixed in 7.1.6
- github.com/mattermost/mattermost-server/v5 (Go): affected from 5.0.0; fixed in 7.1.6
- github.com/mattermost/mattermost-server/v5 (Go): affected from 5.0.0; fixed in 7.1.6
- github.com/mattermost/mattermost-server/v6 (Go): affected from 6.0.0; fixed in 7.1.6
- github.com/mattermost/mattermost-server/v6 (Go): affected from 6.0.0; fixed in 7.1.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-1774/ (Markdown: https://insights.sbomify.com/CVE-2023-1774/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-1774
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-1774
- OSV: https://osv.dev/vulnerability/CVE-2023-1774

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-1774/
Summaries are generated and may contain mistakes; the official description above is the record.
