CVE-2023-1787 Denial of service in GitLab

Medium 4.3 Published Updated

An attacker can cause a search timeout and denial of service by submitting a specific HTML payload in an issue description.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-1787?

CVE-2023-1787 is a medium-severity denial of service vulnerability in Gitlab Gitlab, published on 5 Apr 2023. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An issue has been discovered in GitLab affecting all versions starting from 15.9 before 15.9.4, all versions starting from 15.10 before 15.10.1. A search timeout could be triggered if a specific HTML payload was used in the issue description.

Weakness: CWE-400

Which versions are affected by CVE-2023-1787?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 15.9.015.9.4, 15.10.1

Products include Gitlab Gitlab.

How do I fix CVE-2023-1787?

Upgrade gitlab to a fixed version for your release line: 15.9.4 or 15.10.1.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2023-1787 being exploited?

There is no known exploitation of CVE-2023-1787 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2023-1787, GHSA-xjw7-jpqw-3q4x, UBUNTU-CVE-2023-1787.

Is CVE-2023-1787 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free