# CVE-2023-1787: Denial of service in GitLab

> An attacker can cause a search timeout and denial of service by submitting a specific HTML payload in an issue description.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Apr 2023
- **Updated:** 10 Feb 2025
- **Also known as:** BIT-gitlab-2023-1787, GHSA-xjw7-jpqw-3q4x, UBUNTU-CVE-2023-1787

## What is CVE-2023-1787?

CVE-2023-1787 is a medium-severity denial of service vulnerability in Gitlab Gitlab, published on 5 Apr 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An issue has been discovered in GitLab affecting all versions starting from 15.9 before 15.9.4, all versions starting from 15.10 before 15.10.1. A search timeout could be triggered if a specific HTML payload was used in the issue description.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2023-1787?

1 open source package ship an affected version, including gitlab. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gitlab` | Bitnami | From 15.9.0 | 15.9.4, 15.10.1 |

Products: Gitlab Gitlab.

## How do I fix CVE-2023-1787?

Upgrade gitlab to a fixed version for your release line: 15.9.4 or 15.10.1.

## Is CVE-2023-1787 being exploited?

There is no known exploitation of CVE-2023-1787 in the wild and no public exploit code.

## Other vulnerabilities in Gitlab Gitlab

- [CVE-2026-97229](https://insights.sbomify.com/CVE-2026-97229/): GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound (critical 10.0, exploited in the wild)
- [CVE-2026-85706](https://insights.sbomify.com/CVE-2026-85706/): GitLab Community Edition and Enterprise Edition Path Traversal (critical 10.0, exploited in the wild)
- [CVE-2023-7028](https://insights.sbomify.com/CVE-2023-7028/): GitLab Community and Enterprise Editions Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2021-22205](https://insights.sbomify.com/CVE-2021-22205/): GitLab Community and Enterprise Editions Remote Code Execution (critical 10.0, exploited in the wild)
- [CVE-2021-39935](https://insights.sbomify.com/CVE-2021-39935/): GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF) (medium 6.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-1787 and fix it if it is affected.

What it is: CVE-2023-1787 is a medium-severity denial of service vulnerability in Gitlab Gitlab, published on 5 Apr 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-1787 in the wild and no public exploit code.

Affected packages and fixed versions:
- gitlab (Bitnami): affected from 15.9.0; fixed in 15.9.4, 15.10.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-1787/ (Markdown: https://insights.sbomify.com/CVE-2023-1787/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-1787
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-1787
- OSV: https://osv.dev/vulnerability/CVE-2023-1787

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-1787/
Summaries are generated and may contain mistakes; the official description above is the record.
