{"answers":{"affected":"2 open source packages ship an affected version, including grumpydictator/firefly-iii. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-1788 exists.","fix":"Upgrade grumpydictator/firefly-iii to 6.0.0 or later.","what":"CVE-2023-1788 is a medium-severity vulnerability in firefly-iii/firefly-iii, published on 5 Apr 2023. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-1788 and fix it if it is affected.\n\nWhat it is: CVE-2023-1788 is a medium-severity vulnerability in firefly-iii/firefly-iii, published on 5 Apr 2023. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-1788 exists.\n\nAffected packages and fixed versions:\n- grumpydictator/firefly-iii (Packagist): affected all versions; fixed in 6.0.0\n- grumpydictator/firefly-iii (Packagist): affected all versions; fixed in 6.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-1788/ (Markdown: https://insights.sbomify.com/CVE-2023-1788/index.md)","id":"CVE-2023-1788","markdown":"https://insights.sbomify.com/CVE-2023-1788/index.md","name":"CVE-2023-1788","record":{"aliases":["GHSA-h7vv-46p5-prmh"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Firefly III","requires_auth":"low_privilege","summary":"Attackers can maintain unauthorized access due to insufficient session expiration in Firefly III.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"@huntrdev","cpe":[{"product":"firefly_iii","vendor":"firefly-iii"}],"cvss":{"score":5.4,"severity":"medium","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-613","name":"DEPRECATED: Insufficient Session Expiration"}],"description":"Insufficient Session Expiration in GitHub repository firefly-iii/firefly-iii prior to 6.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Insufficient Session Expiration in firefly-iii/firefly-iii","id":"CVE-2023-1788","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"security_feature_bypass","year":"2023"},"n_packages":2,"n_references":2,"next":{"headline":"Improper Input Validation in firefly-iii/firefly-iii","id":"CVE-2023-1789"},"packages":[{"ecosystem":"Packagist","fixed":["6.0.0"],"introduced":["0"],"last_affected":[],"package":"grumpydictator/firefly-iii","purl":null,"source":"GHSA-h7vv-46p5-prmh"},{"ecosystem":"Packagist","fixed":["6.0.0"],"introduced":["0"],"last_affected":[],"package":"grumpydictator/firefly-iii","purl":"pkg:composer/grumpydictator/firefly-iii","source":"GHSA-h7vv-46p5-prmh"}],"prev":{"headline":"Denial of service in GitLab","id":"CVE-2023-1787"},"products":["firefly-iii/firefly-iii"],"published":"2023-04-05","related":[{"cvss_score":6.5,"headline":"Incorrect Authorization in firefly-iii/firefly-iii","id":"CVE-2023-0298","kev_date_added":null,"published":"2023-01-14"},{"cvss_score":6.5,"headline":"Cross-Site Request Forgery (CSRF) in firefly-iii/firefly-iii","id":"CVE-2021-3728","kev_date_added":null,"published":"2021-08-23"},{"cvss_score":6.5,"headline":"Cross-Site Request Forgery (CSRF) in firefly-iii/firefly-iii","id":"CVE-2021-3730","kev_date_added":null,"published":"2021-08-23"},{"cvss_score":6.3,"headline":"Unrestricted Upload of File with Dangerous Type in firefly-iii/firefly-iii","id":"CVE-2021-3846","kev_date_added":null,"published":"2021-10-19"},{"cvss_score":6.1,"headline":"Firefly III allows webhooks HTML Injection.","id":"CVE-2024-22075","kev_date_added":null,"published":"2024-01-05"},{"cvss_score":6.1,"headline":"Cross-site scripting in n/a","id":"CVE-2019-14667","kev_date_added":null,"published":"2019-08-05"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-02-10","vendors":["firefly-iii"]},"summary":"Attackers can maintain unauthorized access due to insufficient session expiration in Firefly III.","url":"https://insights.sbomify.com/CVE-2023-1788/"}