CVE-2023-1836 Cross-site scripting in GitLab

Medium 4.4 Published Updated

Attackers can execute arbitrary scripts in victim browsers by viewing specially crafted XML files in raw mode, potentially leading to account takeover.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2023-1836?

CVE-2023-1836 is a medium-severity cross-site scripting vulnerability in Gitlab Gitlab, published on 3 May 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

A cross-site scripting issue has been discovered in GitLab affecting all versions starting from 5.1 before 15.9.6, all versions starting from 15.10 before 15.10.5, all versions starting from 15.11 before 15.11.1. When viewing an XML file in a repository in "raw" mode, it can be made to render as HTML if viewed under specific circumstances

Weakness: CWE-79

Which versions are affected by CVE-2023-1836?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 5.1.015.9.6, 15.10.5, 15.11.1

Products include Gitlab Gitlab.

How do I fix CVE-2023-1836?

Upgrade gitlab to a fixed version for your release line: 15.9.6, 15.10.5 or 15.11.1.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2023-1836 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-1836 exists.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2023-1836, GHSA-93c3-fhhf-8qpv, UBUNTU-CVE-2023-1836.

Is CVE-2023-1836 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free