# CVE-2023-1892: Cross-site Scripting (XSS) - Reflected in sidekiq/sidekiq

> Reflected XSS in Sidekiq allows attackers to execute arbitrary scripts in the context of the web interface.

- **Severity:** High 8.3 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 5 Apr 2023
- **Updated:** 10 Feb 2025
- **Also known as:** GHSA-h3r8-h5qw-4r35

## What is CVE-2023-1892?

CVE-2023-1892 is a high-severity cross-site scripting vulnerability in sidekiq/sidekiq, published on 5 Apr 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Cross-site Scripting (XSS) - Reflected in GitHub repository sidekiq/sidekiq prior to 7.0.8.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-1892?

2 open source packages ship an affected version, including sidekiq. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sidekiq` | RubyGems | From 7.0.4 | 7.0.8 |
| `sidekiq` | RubyGems | From 7.0.4 | 7.0.8 |

Products: Contribsys Sidekiq.

## How do I fix CVE-2023-1892?

Upgrade sidekiq to 7.0.8 or later.

## Is CVE-2023-1892 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-1892 exists.

Public exploit code:

- Sidekiq < 7.0.8 - Cross-Site Scripting (nuclei): http/cves/2023/CVE-2023-1892.yaml

## Other vulnerabilities in sidekiq/sidekiq

- [CVE-2023-26141](https://insights.sbomify.com/CVE-2023-26141/): sidekiq Denial of Service vulnerability (high 7.5)
- [CVE-2022-23837](https://insights.sbomify.com/CVE-2022-23837/): Denial of service in sidekiq (high 7.5)
- [CVE-2023-46950](https://insights.sbomify.com/CVE-2023-46950/): Cross-site scripting in n/a (medium 6.1)
- [CVE-2023-46951](https://insights.sbomify.com/CVE-2023-46951/): Cross-site scripting in n/a (medium 6.1)
- [CVE-2021-30151](https://insights.sbomify.com/CVE-2021-30151/): Cross-site Scripting in Sidekiq (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-1892 and fix it if it is affected.

What it is: CVE-2023-1892 is a high-severity cross-site scripting vulnerability in sidekiq/sidekiq, published on 5 Apr 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-1892 exists.

Affected packages and fixed versions:
- sidekiq (RubyGems): affected from 7.0.4; fixed in 7.0.8
- sidekiq (RubyGems): affected from 7.0.4; fixed in 7.0.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-1892/ (Markdown: https://insights.sbomify.com/CVE-2023-1892/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-1892
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-1892
- OSV: https://osv.dev/vulnerability/CVE-2023-1892

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-1892/
Summaries are generated and may contain mistakes; the official description above is the record.
