{"answers":{"affected":"3 open source packages ship an affected version, including pgadmin4. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-1907 in the wild and no public exploit code.","fix":"Upgrade pgadmin4 to 7.0 or later.","what":"CVE-2023-1907 is a high-severity vulnerability in pgadmin:pgadmin, published on 9 Jan 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-1907 and fix it if it is affected.\n\nWhat it is: CVE-2023-1907 is a high-severity vulnerability in pgadmin:pgadmin, published on 9 Jan 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2023-1907 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pgadmin4 (PyPI): affected all versions; fixed in 7.0\n- pgadmin4 (PyPI): affected all versions; fixed in 7.0\n- pgadmin4 (PyPI): affected all versions; fixed in 7.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-1907/ (Markdown: https://insights.sbomify.com/CVE-2023-1907/index.md)","id":"CVE-2023-1907","markdown":"https://insights.sbomify.com/CVE-2023-1907/index.md","name":"CVE-2023-1907","record":{"aliases":["GHSA-7w6r-748w-mh52","PYSEC-2026-1770","UBUNTU-CVE-2023-1907"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["account_takeover","data_read"],"network_reachable":"yes","non_default_config":true,"product_category":"pgAdmin server","requires_auth":"low_privilege","summary":"Concurrent LDAP logins in pgAdmin server mode may attach users to wrong sessions, allowing unauthorized access to other users' data.","user_interaction":"required","vuln_class":"race_condition"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"pgadmin","vendor":"pgadmin"}],"cvss":{"score":8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-276","name":"Incorrect Default Permissions"},{"id":"CWE-488","name":"Exposure of Data Element to Wrong Session"}],"description":"A vulnerability was found in pgadmin. Users logging into pgAdmin running in server mode using LDAP authentication may be attached to another user's session if multiple connection attempts occur simultaneously.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Pgadmin: users authenticated simultaneously via ldap may be attached to the wrong session","id":"CVE-2023-1907","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"race_condition","year":"2023"},"n_packages":3,"n_references":2,"next":{"headline":"SourceCodester Simple Mobile Comparison Website GET Parameter view_category.php sql injection","id":"CVE-2023-1908"},"packages":[{"ecosystem":"PyPI","fixed":["7.0"],"introduced":["0"],"last_affected":[],"package":"pgadmin4","purl":null,"source":"GHSA-7w6r-748w-mh52"},{"ecosystem":"PyPI","fixed":["7.0"],"introduced":["0"],"last_affected":[],"package":"pgadmin4","purl":"pkg:pypi/pgadmin4","source":"GHSA-7w6r-748w-mh52"},{"ecosystem":"PyPI","fixed":["7.0"],"introduced":["0"],"last_affected":[],"package":"pgadmin4","purl":"pkg:pypi/pgadmin4","source":"PYSEC-2026-1770"}],"prev":{"headline":"Memory corruption in ImageMagick","id":"CVE-2023-1906"},"products":["pgadmin:pgadmin"],"published":"2025-01-09","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-08-27","vendors":["pgadmin"]},"summary":"Concurrent LDAP logins in pgAdmin server mode may attach users to wrong sessions, allowing unauthorized access to other users' data.","url":"https://insights.sbomify.com/CVE-2023-1907/"}