# CVE-2023-1979: Auth bypass in Web Stories for WordPress plugin

> Authors can bypass password protection to access protected Web Stories content via the duplication feature.

- **Severity:** Medium 4.9 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 8 May 2023
- **Updated:** 28 Jan 2025
- **Also known as:** GHSA-p77r-crfj-p4f9

## What is CVE-2023-1979?

CVE-2023-1979 is a medium-severity authentication bypass vulnerability in Google Web Stories for WordPress, published on 8 May 2023. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

The Web Stories for WordPress plugin supports the WordPress built-in functionality of protecting content with a password. The content is then only accessible to website visitors after entering the password. In WordPress, users with the "Author" role can create stories, but don't have the ability to edit password protected stories. The vulnerability allowed users with said role to bypass this permission check when trying to duplicate the protected story in the plugin's own dashboard, giving them access to the seemingly protected content. We recommend upgrading to version 1.32 or beyond commit  ad49781c2a35c5c92ef704d4b621ab4e5cb77d68 https://github.com/GoogleForCreators/web-stories-wp/commit/ad49781c2a35c5c92ef704d4b621ab4e5cb77d68

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2023-1979?

It affects 1 product.


Products: Google Web Stories.

## How do I fix CVE-2023-1979?

No fix has been published for CVE-2023-1979 yet. Limit exposure of the affected software until one is available.

## Is CVE-2023-1979 being exploited?

There is no known exploitation of CVE-2023-1979 in the wild and no public exploit code.

## Other vulnerabilities in Google Web Stories for WordPress

- [CVE-2022-3708](https://insights.sbomify.com/CVE-2022-3708/): Web Stories <= 1.24.0 - Server Side Request Forgery (critical 9.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-1979 and fix it if it is affected.

What it is: CVE-2023-1979 is a medium-severity authentication bypass vulnerability in Google Web Stories for WordPress, published on 8 May 2023. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-1979 in the wild and no public exploit code.

Affected product: Google Web Stories for WordPress. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-1979/ (Markdown: https://insights.sbomify.com/CVE-2023-1979/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-1979
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-1979
- OSV: https://osv.dev/vulnerability/CVE-2023-1979

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-1979/
Summaries are generated and may contain mistakes; the official description above is the record.
