CVE-2023-2015 Cross-site scripting in GitLab

Medium 4.4 Published Updated

Reflected XSS in GitLab abuse reports allows attackers to perform arbitrary actions on behalf of victims.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2023-2015?

CVE-2023-2015 is a medium-severity cross-site scripting vulnerability in Gitlab Gitlab, published on 7 Jun 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

An issue has been discovered in GitLab CE/EE affecting all versions starting from 15.8 before 15.10.8, all versions starting from 15.11 before 15.11.7, all versions starting from 16.0 before 16.0.2. A reflected XSS was possible when creating new abuse reports which allows attackers to perform arbitrary actions on behalf of victims.

Weakness: CWE-79

Which versions are affected by CVE-2023-2015?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 15.11.015.11.7, 16.0.2

Products include Gitlab Gitlab.

How do I fix CVE-2023-2015?

Upgrade gitlab to a fixed version for your release line: 15.11.7 or 16.0.2.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2023-2015 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-2015 exists.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2023-2015, GHSA-vx2h-m34g-ggpg, UBUNTU-CVE-2023-2015.

Is CVE-2023-2015 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free