CVE-2023-2017 Improper Control of Generation of Code in Twig Rendered Views in Shopware
Remote attackers with Twig access can bypass validation to execute arbitrary PHP code in Shopware 6.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-2017?
CVE-2023-2017 is a high-severity code injection vulnerability in Shopware Shopware, published on 17 Apr 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Server-side Template Injection (SSTI) in Shopware 6 (<= v6.4.20.0, v6.5.0.0-rc1 <= v6.5.0.0-rc4), affecting both shopware/core and shopware/platform GitHub repositories, allows remote attackers with access to a Twig environment without the Sandbox extension to bypass the validation checks in `Shopware\Core\Framework\Adapter\Twig\SecurityExtension` and call any arbitrary PHP function and thus execute arbitrary code/commands via usage of fully-qualified names, supplied as array of strings, when referencing callables. Users are advised to upgrade to v6.4.20.1 to resolve this issue. This is a bypass of CVE-2023-22731.
Which versions are affected by CVE-2023-2017?
4 open source packages ship an affected version, including shopware/core and shopware/platform. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
shopware/core Packagist | All versions | 6.4.20.1 |
shopware/core Packagist | All versions | 6.4.20.1 |
shopware/platform Packagist | All versions | 6.4.20.1 |
shopware/platform Packagist | All versions | 6.4.20.1 |
Products include Shopware Shopware.
How do I fix CVE-2023-2017?
Upgrade shopware/core to 6.4.20.1 or later.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2023-2017 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-2017 exists.
Other vulnerabilities in Shopware Shopware
- CVE-2023-22731 Improper Control of Generation of Code in Twig rendered views in shopware
- CVE-2016-3109 Shopware RCE Vulnerability
- CVE-2024-22406 Blind SQL-injection in DAL aggregations in Shopware
- CVE-2021-32711 Leak of information via Store-API
- CVE-2026-31887 Shopware unauthenticated data extraction possible through store-api.order endpoint
Sources
Also known as GHSA-7v2v-9rm4-7m8f.