# CVE-2023-2017: Improper Control of Generation of Code in Twig Rendered Views in Shopware

> Remote attackers with Twig access can bypass validation to execute arbitrary PHP code in Shopware 6.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Apr 2023
- **Updated:** 5 Feb 2025
- **Also known as:** GHSA-7v2v-9rm4-7m8f

## What is CVE-2023-2017?

CVE-2023-2017 is a high-severity code injection vulnerability in Shopware Shopware, published on 17 Apr 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Server-side Template Injection (SSTI) in Shopware 6 (<= v6.4.20.0, v6.5.0.0-rc1 <= v6.5.0.0-rc4), affecting both shopware/core and shopware/platform GitHub repositories, allows remote attackers with access to a Twig environment without the Sandbox extension to bypass the validation checks in `Shopware\Core\Framework\Adapter\Twig\SecurityExtension` and call any arbitrary PHP function and thus execute arbitrary code/commands via usage of fully-qualified names, supplied as array of strings, when referencing callables. Users are advised to upgrade to v6.4.20.1 to resolve this issue. This is a bypass of CVE-2023-22731.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-184 (Incomplete List of Disallowed Inputs), CWE-1336 (Improper Neutralization of Special Elements Used in a Template Engine)

## Which versions are affected by CVE-2023-2017?

4 open source packages ship an affected version, including shopware/core and shopware/platform. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `shopware/core` | Packagist | All versions | 6.4.20.1 |
| `shopware/core` | Packagist | All versions | 6.4.20.1 |
| `shopware/platform` | Packagist | All versions | 6.4.20.1 |
| `shopware/platform` | Packagist | All versions | 6.4.20.1 |

Products: Shopware Shopware.

## How do I fix CVE-2023-2017?

Upgrade shopware/core to 6.4.20.1 or later.

## Is CVE-2023-2017 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-2017 exists.

## Other vulnerabilities in Shopware Shopware

- [CVE-2023-22731](https://insights.sbomify.com/CVE-2023-22731/): Improper Control of Generation of Code in Twig rendered views in shopware (critical 10.0)
- [CVE-2016-3109](https://insights.sbomify.com/CVE-2016-3109/): Shopware RCE Vulnerability (critical 9.8)
- [CVE-2024-22406](https://insights.sbomify.com/CVE-2024-22406/): Blind SQL-injection in DAL aggregations in Shopware (critical 9.3)
- [CVE-2021-32711](https://insights.sbomify.com/CVE-2021-32711/): Leak of information via Store-API (critical 9.1)
- [CVE-2026-31887](https://insights.sbomify.com/CVE-2026-31887/): Shopware unauthenticated data extraction possible through store-api.order endpoint (high 8.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-2017 and fix it if it is affected.

What it is: CVE-2023-2017 is a high-severity code injection vulnerability in Shopware Shopware, published on 17 Apr 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-2017 exists.

Affected packages and fixed versions:
- shopware/core (Packagist): affected all versions; fixed in 6.4.20.1
- shopware/core (Packagist): affected all versions; fixed in 6.4.20.1
- shopware/platform (Packagist): affected all versions; fixed in 6.4.20.1
- shopware/platform (Packagist): affected all versions; fixed in 6.4.20.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-2017/ (Markdown: https://insights.sbomify.com/CVE-2023-2017/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-2017
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-2017
- OSV: https://osv.dev/vulnerability/CVE-2023-2017

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-2017/
Summaries are generated and may contain mistakes; the official description above is the record.
