CVE-2023-2022 Missing Authorization in GitLab

Medium 4.3 Published Updated

Developers can create pipeline schedules on protected branches without merge access, allowing unauthorized code execution paths.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-2022?

CVE-2023-2022 is a medium-severity missing authorization vulnerability in Gitlab Gitlab, published on 2 Aug 2023. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An issue has been discovered in GitLab CE/EE affecting all versions starting before 16.0.8, all versions starting from 16.1 before 16.1.3, all versions starting from 16.2 before 16.2.2, which leads to developers being able to create pipeline schedules on protected branches even if they don't have access to merge

Weakness: CWE-262

Which versions are affected by CVE-2023-2022?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiAll versions16.0.8, 16.1.3, 16.2.2

Products include Gitlab Gitlab.

How do I fix CVE-2023-2022?

Upgrade gitlab to a fixed version for your release line: 16.0.8, 16.1.3 or 16.2.2.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2023-2022 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-2022 exists.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2023-2022, GHSA-3cgp-mpf6-c8vw, UBUNTU-CVE-2023-2022.

Is CVE-2023-2022 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free